Opened 10 years ago

Last modified 8 years ago

#1360 closed defect (Not a bug)

Tor Debian Package refuses to build without asciidocs

Reported by: ioerror Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: 0.2.1.25
Severity: Keywords:
Cc: ioerror, nickm, Sebastian, arma, weasel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I don't have asciidocs installed on my Debian Lenny system.
I've edited tor/debian/rules to add '--disable-asciidocs' to the 'config.status: configure' target.

Attempts to build fail:

config.status: creating contrib/suse/Makefile
config.status: creating contrib/suse/tor.sh
config.status: creating orconfig.h
config.status: executing depfiles commands
target="doc/tor.1.in"; base="${target%%.1.in}"; \

a2x -f manpage "$base".1.txt && \
if [ -e "$base".1 ]; then mv "$base".1 "$base".1.in; \
elif [ -e "$base".8 ]; then mv "$base".8 "$base".1.in; \
else echo >&2 "No output produced by a2px?" && exit 1; fi

/bin/sh: line 1: a2x: command not found
make: * [doc/tor.1.in] Error 127
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
debuild: fatal error at line 1319:
dpkg-buildpackage -rfakeroot -d -us -uc failed

I've solved this by simply installing the Debian package 'asciidoc'; I'll debug it later.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (4)

comment:1 Changed 10 years ago by arma

I haven't looked in detail, but it's conceivable that the bug will be solved,
or at least different, in 0.2.2.11-alpha. So be sure to compare to the new deb
when resolving.

comment:2 Changed 10 years ago by Sebastian

The Debian package is not supposed to build without asciidoc,
and this dependency is mentioned in the build-depends line.

If you manually change the debian/rules file, you'll have to make
sure to also make other changes so that the package can still
build.

comment:3 Changed 10 years ago by Sebastian

flyspray2trac: bug closed.

comment:4 Changed 8 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.