Opened 5 years ago

Closed 2 years ago

#13601 closed defect (user disappeared)

TOR + VPN = No TOR-ARM reporting.

Reported by: shredder Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.5.10
Severity: Normal Keywords: ARM
Cc: atagar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Sorry if this has been asked before, I could not find my specific question here.

I am using a VPN service called Private Internet Access, I'm sure most of you are familiar. I also have a TOR relay setup on this same desktop. I noticed that when I flipped on my VPN that TOR-ARM[1] would stop displaying the graphical charts.

My question is: Should i stop my relay when I start my VPN or is everything working as normal but not being reported correctly by Tor-ARM because of, maybe, the interface the connection it is passing through isn't monitored by ARM?

Note: If I stop, and restart TOR and TOR-ARM while the VPN is running I get a blip on the charts but nothing significant.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by nickm

Cc: atagar added
Milestone: Tor: unspecified
Status: newneeds_information

Damian, could this be an Arm issue?

comment:2 Changed 4 years ago by atagar

If the graph stops updating then that indicates that arm stopped receiving BW events. This could mean that switching to the VPN breaks our established controller connection, or that tor stops emitting them.

Arm should be emitting a heartbeat message saying 'hey, I haven't received any BW events in a while' if either of the above is the case. I can't say with this little information what's up.

comment:3 Changed 2 years ago by nickm

Resolution: user disappeared
Severity: Normal
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.