Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#13629 closed defect (fixed)

Cannot login to the Cypherpunks account

Reported by: cypherpunks-duplicate Owned by:
Priority: Immediate Milestone:
Component: Internal Services/Service - trac Version:
Severity: Normal Keywords:
Cc: qbi Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mrphs)

The dummy account 'cypherpunks' with password 'writecode' doesn't work anymore.

cypherpunks user account shouldn't be able to change their password.

Child Tickets

Change History (16)

comment:1 Changed 5 years ago by mrphs

Description: modified (diff)
Priority: majorblocker

Confirmed. I've also changed the priority to blocker.

comment:2 Changed 5 years ago by mrphs

Description: modified (diff)

comment:3 Changed 5 years ago by arma

Well, I made the account work again.

But I didn't do the "go into the code, and for the password changing function make it fail when username==cypherpunks" part.

comment:4 Changed 5 years ago by cypherpunks

Duplicate of #12034

comment:5 Changed 5 years ago by cypherpunks-duplicate

stopped working again.

comment:6 Changed 5 years ago by cypherpunks

I recreated cypherpunks, now it works (?)

comment:7 in reply to:  6 Changed 5 years ago by cypherpunks

Replying to cypherpunks:

I recreated cypherpunks, now it works (?)

No

comment:8 Changed 5 years ago by anon

I suggest using a script to sed the cypherpunks account back to a fixed / known good digest. E.g.:

while inotifywait -e modify /path/to/.htpasswd; do

echo sed to fixed good for your auth here.

done

comment:9 Changed 5 years ago by cYphErPUNKs

Why you need cpunks account? Devs will ignore you anyway, with cpunks or another account either. Drop trac, don't waster your time. In the name of sanity.

comment:10 Changed 5 years ago by cYphErPUNKs

[Removed yet another instance of that stupid .SVG]

Last edited 5 years ago by yawning (previous) (diff)

comment:11 Changed 4 years ago by cypherpunks_backup

Severity: Normal

At the time of writing this, the cypherpunks account again does not work.

comment:12 Changed 4 years ago by yawning

Cc: qbi added

Bob fucked with it (again?). We really should modify trac to prevent this from happening, though that likely won't happen till after people are back from CCC.

comment:13 Changed 4 years ago by qbi

I reset the password. However we need to find a better solution.

comment:14 Changed 4 years ago by cypherpunks-duplicate

Happy new year! It's happening again!

comment:15 Changed 4 years ago by qbi

Resolution: fixed
Status: newclosed

Thanks for the notice.
The user+password will now updated/checked on a regular basis.

comment:16 in reply to:  15 Changed 4 years ago by cypherpunks

Replying to qbi:

Thanks for the notice.
The user+password will now updated/checked on a regular basis.

Seems like a cat and mouse game. Is it not possible to lock down the password of cypherpunks so it cannot be changed?

Note: See TracTickets for help on using tickets.