Opened 5 years ago

Closed 5 years ago

#13644 closed defect (fixed)

ROUTER_WAS_NOT_NEW and ROUTER_WAS_TOO_OLD are confusingly confusable

Reported by: nickm Owned by: rl1987
Priority: Very Low Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client doc
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We should document every was_router_added_t value. And we should rename the values that are confusable, notably "ROUTER_WAS_NOT_NEW" and "ROUTER_TOO_OLD": They mean different things, but the names sure don't make that clear.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by rl1987

Owner: set to rl1987
Status: newaccepted

comment:2 Changed 5 years ago by rl1987

Status: acceptedneeds_review

https://github.com/rl1987/tor/commits/bug13644

comment:3 Changed 5 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

lgtm; merging!

Note: See TracTickets for help on using tickets.