Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13659 closed defect (wontfix)

Drop Windows entirely

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Archived/Development Progress Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Windows is proprietary commercial spy poisoned software.
You can't to build solid software for windows without closed source compilers produced by M$. Every piece of software like MinGW (includes port of GCC) lacks of many closed, patented part of used run-time code from Visual Studio, which strongly need to produce correct code.
It's especially true for C++ code, but valid for C code, where it lacks of some features.
See #13443 for example for C++ code or #10186 for lack of stack tracing for code compiled by GCC.

Child Tickets

Change History (15)

comment:1 Changed 4 years ago by cypherpunks

None of the developers use any of windows. This and broken cross-platform compilation due mingw incompleteness by design. Double reason to drop windows.

comment:2 Changed 4 years ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #13654.

comment:3 Changed 4 years ago by cypherpunks

Resolution: duplicate
Status: closedreopened

Not it's different bug, not duplicate.

comment:4 Changed 4 years ago by yawning

Resolution: wontfix
Status: reopenedclosed

comment:5 Changed 4 years ago by cypherpunks

Why?

comment:6 in reply to:  4 ; Changed 4 years ago by cypherpunks

Replying to yawning:

Are you using any of windows?

comment:8 Changed 4 years ago by cypherpunks

WINDOWS WINDOWS WINDOWS [...several thousand instances of 'WINDOWS' deleted...]

Last edited 4 years ago by nickm (previous) (diff)

comment:10 Changed 4 years ago by nickm

I can understand that you might not like it if somebody disagrees with you, but this is no way to respond. Please do not do this any more.

comment:11 Changed 4 years ago by cypherpunks

nobody explained anything. wontfix not an explanation

comment:12 Changed 4 years ago by nickm

If you want people to respond to you, waiting 8 minutes after you ask a question, then flooding the ticket is not the way. When you do stuff like that, it makes me upset, and it does not make me feel like you are actually waiting for an explanation.

comment:13 in reply to:  3 Changed 4 years ago by cypherpunks

waiting 8 minutes after you ask a question,

10 minutes. And yet 7 minutes till WINDOWS.

Replying to 2014-11-04 15:20:06 yawning:

Duplicate of #13654.

Replying to 2014-11-04 15:23:06 cypherpunks:

Not it's different bug, not duplicate.

Replying to 2014-11-04 15:30:23 yawning:

Resolution set to wontfix

comment:14 Changed 4 years ago by nickm

I don't think flooding the ticket is okay or welcome, whether you wait 10 minutes for an answer, 20 minutes for an answer, or even a day. When somebody floods a ticket at all, it makes me think that they do not really want to talk or listen.

If you really want a response here, please be patient.

comment:15 Changed 4 years ago by cypherpunks

You can't develop cats outside of Schrödinger's box, you need to be inside.
Windows is Schrödinger's box, and you can't to detect spin of cat even because MinGW will never be complete.

comment:16 Changed 4 years ago by cypherpunks

or even a day.

or even never.

comment:17 in reply to:  6 Changed 4 years ago by yawning

Replying to cypherpunks:

Replying to yawning:

Are you using any of windows?

When I need to, yes. I have a Windows box that I used to test/debug the firewall helper stuff that I have been poking at. It's not my primary development platform, and I don't do Tor Browser development on it, but the core tor code and the PT code are all written to run on Windows (though this too can use improvement).

The unfortunate reality is that a lot of our users use Windows for various reasons, some beyond their control, and it is unrealistic to drop support as a platform at this time. If you think our Windows situation could be improved if we supported a MSVC firefox build, or devoted further engineering efforts to improving the state of MinGW, please file separate tickets.

Note: See TracTickets for help on using tickets.