Opened 3 years ago

Closed 20 months ago

#13721 closed defect (fixed)

TorBirdy 0.1.2 uses wrong locale

Reported by: dkaeae Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Normal Keywords: torbirdy-0.1.5
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Thunderbird 31.2.0, LinuxMint 17.

My locale (LANG) is set to ja_JP.UTF-8, and I also have the English (US) localization packages installed through the packet manager.

Problem: TorBirdy is in Arabic.

Expected behaviour: TorBirdy is in Japanese (my default locale) or English.

Child Tickets

Change History (13)

comment:1 Changed 3 years ago by sukhbir

I see that you are using 0.1.2. Can you try this with the latest version (0.1.3; https://dist.torproject.org/torbirdy/torbirdy-current.xpi) and then report if you still face this issue?

comment:2 Changed 3 years ago by dkaeae

0.1.3 is still in Arabic.

comment:3 Changed 3 years ago by sukhbir

This is very odd and might be a bug. Since there is no Japanese language pack for Thunderbird, we don't ship the Japanese translation of TorBirdy. We will change that in the next release by shipping placeholder strings instead.

Though I am still not sure why it defaults to Arabic (probably because it is the first locale in chrome.manifest?) Unsure.

I will check this.

comment:4 Changed 3 years ago by sukhbir

Any update on this? Not that it will magically resolve itself (!) but maybe you found out the cause or have an update since I can't reproduce this issue.

comment:5 Changed 3 years ago by dkaeae

It's still an issue here...

I've also tried changing the locale to English (export LANG=en_US.UTF-8). This makes TorBirdy start correctly in English.

I think the problem might be that TorBirdy doesn't find a language pack for Japanese and then defaults to the first language it can find --- and like you said Arabic seems a good candidate for that, since it starts with an "A" :)

Of course, this is just a hunch; I haven't taken a look at the source code or anything.

comment:6 Changed 3 years ago by dkaeae

BTW this is still a problem in TorBirdy 0.1.4 (this time I'm using LinuxMint 17.1, Thunderbird 31.6.0).

comment:7 Changed 3 years ago by sukhbir

Keywords: torbirdy-0.1.5 added

comment:8 Changed 2 years ago by kytv

I'm working on integrating Icedove and Torbirdy in Tails and I also ran into this problem. This can be reproduced in a Vietnamese locale, one of Tails' supported languages. It is almost certainly reproducible in other locales too.

In this case there is a Vietnamese language pack installed for Icedove. Icedove's interface is displayed in Vietnamese but Torbirdy is in Arabic.

comment:9 Changed 2 years ago by kytv

Tails is tracking this problem at https://labs.riseup.net/code/issues/9821.

comment:10 Changed 2 years ago by anonym

Speaking from experience with a very similar bug in Tor Launcher, that was fixed ~a year ago, I very much believe the issue is that in chrome.manifest there is:

    locale castironthunderbirdclub en chrome/locale/en/

but this should be "en-US" for us to get (US) English as the default locale. The XUL localization system does treat "en-US" as the hardcoded default, but only if it is (exactly) present in the list of locales in chrome.manifest, otherwise it'll just pick the first one, which tends to be ar = Arabic. So a correct line instead of the "en" one would be:

    locale castironthunderbirdclub en-US chrome/locale/en/

It may even be worth to rename chrome/locale/en to chrome/locale/en-US and then instead add:

    locale castironthunderbirdclub en-US chrome/locale/en-US/

but then a similar renaming must be done in transifex, I guess.

comment:11 in reply to:  10 Changed 2 years ago by kytv

Replying to anonym:

So a correct line instead of the "en" one would be:

    locale castironthunderbirdclub en-US chrome/locale/en/

I have confirmed that this will fix the problem.

Please consider merging this pull request and making an updated Addon available.

Thanks in advance. :)

comment:12 Changed 20 months ago by sukhbir

Severity: Normal

Fixed in 3d625f. Thanks everyone!

comment:13 Changed 20 months ago by sukhbir

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.