Opened 3 years ago

Closed 3 years ago

#13722 closed defect (fixed)

TorBirdy 0.1.3 prevents Thunderbird from starting

Reported by: dkaeae Owned by: ioerror
Priority: High Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: ter.one.leeboi@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Thunderbird 31.2.0, LinuxMint 17.

Installed TorBirdy 0.1.3 from the link here:
https://blog.torproject.org/blog/torbirdy-013-our-fourth-beta-release

Problem: Thunderbird won't start after installing TorBirdy. The process eats more and more memory while using 100% CPU.

Expected behaviour: Thunderbird starts and TorBirdy is working.

Child Tickets

Change History (13)

comment:1 Changed 3 years ago by sukhbir

Since you are on Mint, can you start Thunderbird from the terminal and paste the output? (removing sensitive information, if any.)

I doubt that this is a TorBirdy issue since we are not doing much at startup but we should check this nevertheless. Can you try this with a clean profile (`thunderbird -p`)?

comment:2 Changed 3 years ago by dkaeae

The output follows (it does not seem that verbose though, maybe there is some debug option I am not aware of):

(process:6573): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(thunderbird:6573): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(thunderbird:6573): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(thunderbird:6573): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(thunderbird:6573): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

Using a clean profile, it magically works. Could it be some conflict with another add-on? I am using the following:

  • Enigmail 1.7.2 (PGP)
  • Inverse SOGo Connector 31.0.0 (contact sync)
  • Lightning 3.3.1 (calendars)
  • Messaging Menu and Unity Launcher integration 1.3.1 (automatically installed by Ubuntu/Mint)

So nothing connection- or Tor-related.

comment:3 Changed 3 years ago by sukhbir

I am pretty sure Lightning has no issues with TorBirdy. In any case, can you try disabling these add-ons one by one and see if it fixes the problem? First disable them one by one. Then enable TorBirdy and then disable them. (I think it might be SOGo.)

comment:4 Changed 3 years ago by dkaeae

It still hangs with all add-ons disabled.

I have tried starting with a clean profile again, install TorBirdy, and add an email account. However, sending messages does not work, nor does fetching email. There is no error message or similar as well.

comment:5 Changed 3 years ago by Viggy_prabhu

Hi dkaeae,

When you started TOR on clean profile, was your TOR Browser Bundle(TBB) or TOR Daemon running? Not sure if you know this already but TBB or TOR Daemon should be running when you want to use TORBirdy as the proxy needs to be configured to port 9150 or 9050 respectively.
Kindly ignore this in case you knew this already.

comment:6 in reply to:  4 Changed 3 years ago by sukhbir

Replying to dkaeae:

It still hangs with all add-ons disabled.

I have tried starting with a clean profile again, install TorBirdy, and add an email account. However, sending messages does not work, nor does fetching email. There is no error message or similar as well.

Any update? (See viggy_prabhu's comment also.)

comment:7 Changed 3 years ago by MaximumShower

I also have this issue. Thunderbird 31.3.0 TorBirdy 0.1.3 on Ubuntu 14.04.

Starting thunderbird with torbirdy enabled (and tor daemon running on 9050) fails to open UI, although process continues running and eventually uses 100% of CPU. Disabling all other addons does not fix problem. However starting thunderbird with a fresh profile does enable it to start with torbirdy.

See also #14007 which appears to be the same problem.

Last edited 3 years ago by MaximumShower (previous) (diff)

comment:8 Changed 3 years ago by Viggy_prabhu

Can we use this add-on, Log-Helperto get some useful logs from thunderbird? Also #14130 seem to be also the same issue.

comment:9 Changed 3 years ago by cypherpunks

I also have this problem. With Thunderbird 31.4 using TorBirdy v0.1.3. I have to remove the install file to get Thunderbird to start after it's installed (so I can't use TorBirdy).

The Thunderbird process starts and get up to near 75K memory usage but the UI never loads. So I then have to kill the process and remove the install file to get Thunderbird's UI to load.

I was able to use TorBirdy with Thunderbird for a long while, but when I tried it today (after a long time not using it) I found this problem. I was going to open a ticket but I noticed this one is already opened.

I'm on Windows 7 with zero other extensions and zero plugins installed other than TorBirdy.

Last edited 3 years ago by cypherpunks (previous) (diff)

comment:10 Changed 3 years ago by cypherpunks

Isn't this the same bug as #14007?

comment:11 Changed 3 years ago by lolol

i suddenly had this problem today after temporarily disabling the torbirdy addon because it was slow and i had a lot of emails to download (yes stupid reason, but it was messing up a lot). when i finished, i enabled torbirdy again and tried restarting thunderbird but it wouldnt start anymore.

i finally fixed it by doing this:
i have a seperate thunderbird profile which is mostly the same as the one which stopped working, except different accounts. i looked at the directories of each profile and made sure they matched. meaning i deleted some cache folders and other seemingly rubbish files from the broken profile which werent apparent in the good profile. though i dont think this is what helped. what i think helped was:

opened up prefs.js of both profiles and did a compare and copied all missing preferences from the good profile to the broken one. they were mostly preferences torbirdy added i think. also torbirdy was uninstalled in that profile at this point. and then i reinstalled torbirdy and it works fine now.

tl;dr: run thunderbird in safe mod and remove the torbirdy addon. close thunderbird. copy all missing preferences into prefs.js from a working profile which has torbirdy. open thunderbird and reinstall torbirdy extension. restart thunderbird and it should work now. im using thunderbird 31.4.0 on windows 8

comment:12 Changed 3 years ago by leeroy

Cc: ter.one.leeboi@… added

comment:13 Changed 3 years ago by sukhbir

Resolution: fixed
Status: newclosed

Fixed with TorBirdy 0.1.4. Please upgrade!

Note: See TracTickets for help on using tickets.