Opened 6 years ago

Closed 6 years ago

#13732 closed defect (not a bug)

ennable seccomp for deb.torproject.org Tor package

Reported by: proper Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor from deb.torproject.org comes without seccomp support.

dpkg-query --show --showformat='${Version}\n' "tor"
0.2.5.10-1~d70.wheezy+1
```

With Sandbox 1 in /etc/tor/torrc.

tail -f /var/run/tor/log 
sudo service tor restart
[warn] This version of Tor was built without support for sandboxing. To build with support for sandboxing on Linux, you must have libseccomp and its necessary header files (e.g. seccomp.h).

You don't have to enable seccomp by default, but could you please compile with secomp support by default to enabler easier and wider testing?

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by weasel

Component: Tor Sysadmin Team- Select a component
Resolution: not a bug
Status: newclosed

seccomp is available in jessie and later.

Note: See TracTickets for help on using tickets.