Opened 5 years ago

Closed 5 years ago

#13733 closed defect (not a bug)

tor should not stop for a change of the config value DisableDebuggerAttachment

Reported by: toralf Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.5.10
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If the config value DisableDebuggerAttachment is changed (to let arm show the inbound/outbound connections at page 2 of the arm tool too, otherwise just circuits are shown) and tor is advised to re-read the config file, it stops with :

Nov 11 19:33:44.000 [warn] Failed to parse/validate config: While Tor is running, disabling DisableDebuggerAttachment is not allowed.
Nov 11 19:33:44.000 [err] Reading config failed--see warnings above. For usage, try -h.
Nov 11 19:33:44.000 [warn] Restart failed (config error?). Exiting.

This is a bad behaviour in my eyes.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by yawning

Not allowing DisableDebuggerAttachment to be disabled while Tor is running is *very* explicit and intentional behavior and will not be changed (#4650). For what it's worth SETCONF provides a more graceful failure mode here.

Perhaps SIGHUP should be more resilient to configuration reload failures, but that's entirely unrelated to DisableDebuggerAttachment and should probably be a separate ticket.

(My gut feeling says to WONTFIX/NOTABUG this, though I'll wait for nickm or someone else to make the decision here.)

comment:2 Changed 5 years ago by yawning

Resolution: not a bug
Status: newclosed

Per discussion with nickm:

There could be a better failure mode for SIGHUP, but DisableDuggerAttachment has to be undisableable.

Please file another ticket for the SIGHUP issue if you think it's appropriate. Past that there isn't anything to fix here since the behavior is intentional and documented (in the man page).

Note: See TracTickets for help on using tickets.