Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#1374 closed defect (fixed)

No connection anymore

Reported by: anonymous Owned by: phobos
Priority: Low Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.1.25
Severity: Keywords: connection network
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

HI,
I am running as Guard Router using Tor IM Browser 0.2.1.25 and Windows 7. After a few days, not using Tor myself, my Firefox and IE lost all contact to the network. Polipo and Vidalia processes are running. I think Firefox is talking to Polipo. View Network in Vidalia doesn’t show any Connections. Tor traffic is still flowing as usual at full speed. I had the same problem with version 0.2.1.24. After restart of the computer the program works fine again.
Best Regards
STHnet

Child Tickets

Attachments (1)

VidaliaLog-06.12.2010.txt (9.7 KB) - added by cypherpunks 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by phobos

Owner: set to phobos
Status: newaccepted

We need log files to help you.

comment:2 Changed 10 years ago by phobos

Adding from 1375,

504 Connect to www.geobytes.com:80 failed: SOCKS error: TTL expired

The following error occurred while trying to access http://www.geobytes.com/ipLocator.htm:

504 Connect to www.geobytes.com:80 failed: SOCKS error: TTL expired
Generated Tue, 27 Apr 2010 21:49:57 Västeuropa, sommartid by Polipo on localhost:8118.

comment:3 Changed 10 years ago by phobos

Component: Polipo-Backend / CoreTor-Tor bundles/installation

comment:4 Changed 10 years ago by phobos

The same problem with TBB 0.2.1.26. The problem is no directory fetches anymore.
Best Regards
STHnet

maj 11 17:57:44.555 [Notice] Tor v0.2.1.26. This is experimental software. Do not rely on it for strong anonymity. (Running on Very recent version of Windows [major=6,minor=1] [workstation] {personal} {terminal services, single user})
maj 11 17:57:44.586 [Notice] Your ContactInfo config option is not set. Please consider setting it, so we can contact you if your server is misconfigured or something else goes wrong.
maj 11 17:57:44.586 [Notice] Initialized libevent version 1.4.12-stable using method win32. Good.
maj 11 17:57:44.586 [Notice] Opening OR listener on 0.0.0.0:443
maj 11 17:57:44.586 [Notice] Opening Socks listener on 127.0.0.1:9050
maj 11 17:57:44.586 [Notice] Opening Control listener on 127.0.0.1:9051
maj 11 17:57:44.586 [Notice] Parsing GEOIP file.
maj 11 17:57:49.827 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
maj 11 17:57:49.827 [Notice] Bootstrapped 100%: Done.
maj 11 17:57:50.311 [Notice] Now checking whether ORPort 217.208.70.200:443 is reachable... (this may take up to 20 minutes -- look for log messages indicating success)
maj 11 17:58:32.339 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
maj 11 17:59:16.238 [Notice] Performing bandwidth self-test...done.
maj 12 20:58:35.521 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'dataway'. Retrying on a new circuit.
maj 13 10:58:36.594 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'KeithsReturn'. Retrying on a new circuit.
maj 13 11:10:18.983 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 12:58:35.572 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'PolandOnion'. Retrying on a new circuit.
maj 13 16:58:36.475 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Qwerty'. Retrying on a new circuit.
maj 13 22:04:09.178 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:29.667 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:29.667 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:13:16.742 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:15:09.343 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:19:25.948 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 11:13:07.807 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 11:14:45.166 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 17:51:45.006 [Notice] Tried for 121 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 17:58:51.090 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:13:56.500 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:15:21.722 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:15:21.722 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:17:00.143 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:17:00.143 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 17 18:58:36.825 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'blutmagie2'. Retrying on a new circuit.
maj 17 20:58:40.683 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'blutmagie2'. Retrying on a new circuit.
maj 18 14:58:39.629 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Jisunglove'. Retrying on a new circuit.
maj 18 14:58:54.839 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'ZiMnEpIwO'. Retrying on a new circuit.
maj 18 15:58:36.605 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Shitblaster'. Retrying on a new circuit.
maj 18 19:00:26.103 [Notice] Our directory information is no longer up-to-date enough to build circuits: We have no recent network-status consensus.
maj 18 19:58:12.366 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 20:00:02.907 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 20:58:03.684 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 21:00:03.465 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 21:58:02.780 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 22:00:02.956 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 22:09:37.882 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 22:11:37.050 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)

comment:5 Changed 10 years ago by phobos

Can you switch to info level logs and post the results?

Changed 10 years ago by cypherpunks

Attachment: VidaliaLog-06.12.2010.txt added

comment:6 Changed 10 years ago by cypherpunks

OK file added.

comment:7 Changed 9 years ago by phobos

Odd that it detects your orport is reachable, but cannot find your local IP correctly.

Do you have a local firewall? Or proxy server you have to use to get to the Internet? I don't see one configured.

comment:8 Changed 9 years ago by cypherpunks

Yes I have a NAT & SPI firewall but I don´t think that’s the problem since I have been running as a Tor router since 2008 with the same firewall. Before this year I used the installed Windows version of Tor. Changing to Windows 7 I started to use TBB instead since I can run TBB on an ordinary user account without privileges. The traffic on my slow ADSL output have always been full before and therefore I don´t mirror the relay directory. Maybe the latter has something to do with the problem? TBB 0.2.1.6 have the same problem. After a while the traffic is shrinking drastically to almost zero, but a couple of connections still exist.

comment:9 Changed 9 years ago by cypherpunks

I also agree. It is odd that TBB is always checking if ORPort 217.208.70.200:443 is reachable and after that forgets all about the public address. I will try to code the address in torrc to see if any change in behavior. Not a good final solution since I have dynamic address allocation.

comment:10 Changed 9 years ago by arma

"View Network in Vidalia doesn’t show any Connections" is normal if you're
a relay and haven't used your Tor as a client lately.

If your DirPort is off, and you haven't used your Tor as a client lately, your
Tor will stop fetching relay descriptors. After all, nobody is going to need them.

When you *do* use your Tor as a client again, Tor will notice and resume fetching
descriptors, as you see in
maj 18 19:58:12.366 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.

It looks like STHnet is happily running as part of the network, so I don't think the
address detection stuff is failing.

But I'm confused about the bug report. You say "Tor traffic is still flowing as usual at full speed" and then you say "After a while the traffic is shrinking drastically to almost zero". Which is it?

The other part of the bug is that when you click on something as a client, when your Tor
has been dormant for a long time, it takes Tor a while to wake up. Does it never wake up?
Maybe that's the bug here?

comment:11 Changed 9 years ago by cypherpunks

I only use Tor when I need to and could therefore leave Tor running for weeks not using the system for myself. I know that it could take time for Vidalia to wake up since I have experienced that before.

The behavior of the system has changed since I first reported the error. The first time I could see a lot of traffic going but I could not get any connection through Firefox, with Firefox Portable 3.5.10 or ordinary Firefox 3.6.6 (proxy configured). This is perhaps the real error. As you say Tor never wakes up.

What I now observe is that after 5-7 days the traffic is almost dying, instead if increasing. I still have the problem above. I could also have been using Tor myself the day before.

Another interesting observation is the difference between actual capacity presented by Vidalia and capacity presented https://torstatus.blutmagie.de/. At the moment 79.97 v.s. 15.81 KB. I have seen that firewall SPI on/off affect Tor Status, but Vidalia estimate is right and I assume it is used for routing.

(I would not recommend anybody to become a Tor router without a really good firewall since you get a lot of portscans even if you not an exit.)

comment:12 Changed 9 years ago by cypherpunks

Running Tor router for a week after adding address in torrc
Everything looks good. Firefox is working and traffic is flowing.

comment:13 Changed 9 years ago by phobos

Resolution: fixed
Status: acceptedclosed

comment:14 Changed 7 years ago by nickm

Milestone: Tor: 0.2.1.x-final

Milestone Tor: 0.2.1.x-final deleted

Note: See TracTickets for help on using tickets.