Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13741 closed enhancement (not a bug)

do not (re-load) torrc if DisableDebuggerAttachment was changed

Reported by: toralf Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.5.10
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is a fall out from ticket #13733.

Changing DisableDebuggerAttachment and sending SIGHUP to tor stops it.
This is unexpected by a user.

IMO a warning that the current torrc will not be loaded due to the constraint related the change of this config value would be a better approach.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by Sebastian

Resolution: not a bug
Status: newclosed

"Disabling this option while Tor is running is prohibited" is documented in the manpage.

comment:2 Changed 5 years ago by nickm

It's also prohibited for a reason: the code we need to run to disable debugger supervision needs to be permanent. The operating system won't let us turn this option off on a running process, I believe.

comment:3 Changed 4 years ago by toralf

ok, so a change in Gentoo's init script like this :

-       start-stop-daemon --signal HUP --pidfile ${PIDFILE}
+       /etc/init.d/tor --verify-config
+       if [[ $? -eq 0 ]]; then
+               start-stop-daemon --signal HUP --pidfile ${PIDFILE}
+       else
+               eerror "config is wrong, can't reload Tor !"
+       fi

would help ?

comment:4 Changed 4 years ago by Sebastian

No, that wouldn't help because the new config is valid when Tor gets restarted.

Note: See TracTickets for help on using tickets.