Opened 4 years ago

Closed 4 years ago

#13773 closed defect (invalid)

Voting trouble since longclaw joined the network

Reported by: Sebastian Owned by:
Priority: High Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: micah Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Since longclaw joined the dirauths, we've had some trouble getting all dirauths agreeing on a consensus reliably. Logs indicate that the problem is not the typical "not all votes are distributed to everyone in time", but rather it looks like dirauths have the same votes yet calculate different consensuses out of them. How do we best debug this? Is the generated consensus saved anywhere or can we dump it easily to compare and quickly confirm/rule out this hypothesis?

Child Tickets

Change History (8)

comment:1 Changed 4 years ago by micah

Cc: micah added

comment:2 Changed 4 years ago by nickm

I think that the consensus each dirauth generates should be the one it stores locally? If not, you could write it to a file at the end of networkstatus_compute_consensus(). Make sure to use a different file for each flavor.

Also, is there anything suggestive in the logs?

Also, if somebody *didn't* add longclaw and remove turtles, then the expected behavior would be that not everybody reaches the same consensus. Have we ruled that out?

comment:3 in reply to:  2 Changed 4 years ago by Sebastian

Replying to nickm:

I think that the consensus each dirauth generates should be the one it stores locally? If not, you could write it to a file at the end of networkstatus_compute_consensus(). Make sure to use a different file for each flavor.

It doesn't get stored if it isn't valid because it has just one signature, for example I think. I'll check that, thanks for the suggestion.

Also, is there anything suggestive in the logs?

No, that's why I opened the ticket to look more at this.

Also, if somebody *didn't* add longclaw and remove turtles, then the expected behavior would be that not everybody reaches the same consensus. Have we ruled that out?

Yes, most of the time it works, the issues are spurious.

comment:4 Changed 4 years ago by nickm

When the consensus fails, is it always the same authority or authority that doesn't sign it? Or does it seem more or less random?

If some authorities in particular seem to be left out of the consensus -- what version are they running? And what versions are the others running?

comment:5 Changed 4 years ago by Sebastian

It's different dirauths on 0.2.5.10 so far, no pattern. The others are on either 0.2.5.10 or 0.2.6.1

comment:6 Changed 4 years ago by Sebastian

This might've been related to the network trouble longclaw had initially, which would put us back into better-known territory for the issues

comment:7 Changed 4 years ago by nickm

Is this still happening? Or can we close this?

comment:8 Changed 4 years ago by Sebastian

Resolution: invalid
Status: newclosed

I'll close it for now. I think it was related to the well-known voting issues with unstable connections

Note: See TracTickets for help on using tickets.