Opened 5 years ago

Closed 5 years ago

Last modified 18 months ago

#13787 closed defect (fixed)

chutney doesn't seem to bootstrap with master

Reported by: nickm Owned by: teor
Priority: High Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: tom Actual Points:
Parent ID: #13718 Points:
Reviewer: Sponsor:

Description

When I run Chutney with a branch off the latest master, all the nodes have 0 bandwidth, and nobody has the Fast or HSDir flag. I think this is what is making everybody but the authorities fail with:

Nov 18 11:38:18.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Nov 18 11:39:19.000 [warn] No available nodes when trying to choose node. Failing.
Nov 18 11:39:19.000 [warn] No available nodes when trying to choose node. Failing.
Nov 18 11:39:19.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Nov 18 11:39:28.000 [warn] No available nodes when trying to choose node. Failing.
Nov 18 11:39:28.000 [warn] No available nodes when trying to choose node. Failing.
Nov 18 11:39:28.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.

Clearly, this should get fixed. Do we already have a ticket for this?

Child Tickets

Change History (8)

comment:1 Changed 5 years ago by nickm

Cc: teor added

Teor, is this a duplicate of something you've been looking at?

comment:2 Changed 5 years ago by teor

#13161 and #13163 fixed the issues that occurred on each run for me.

But #13718 appears to be the same issue as this one - what do you think?
(See my comments there and the original bug report.)

comment:3 Changed 5 years ago by tom

Cc: tom added

I'll try and look into it also, but I don't see those warnings in my relay that is stuck on #13718 - so it's probably different in some way.

comment:4 Changed 5 years ago by teor

Owner: set to teor
Parent ID: #13718
Status: newassigned

Track along with #13718

comment:5 Changed 5 years ago by teor

Status: assignedneeds_review

The changes to tor in #13718 might have fixed this:

Bugs: #13718, #13814, maybe #13787, #13839, #13924, #13823, #13929, #13963
Branch: bug13718-fast-bootstrap
Note: There are 5 branches that start with bug13718, please choose the right one.
Repository: ​​​​​​​​https://github.com/teor2345/tor.git

comment:6 Changed 5 years ago by nickm

see #13718; merged. I believe this is now solved.

comment:7 Changed 5 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

comment:8 Changed 18 months ago by teor

Cc: teor removed

Remove useless CC

Note: See TracTickets for help on using tickets.