Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1380 closed defect (duplicate)

Adding DirListenAddress Abends Tor on HUP

Reported by: BarkerJr Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.12-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

0.2.2.13

Scenario:
Tor is currently listening for directory requests at 0.0.0.0:9030. Add DirListenAddress to specify that it should use <specific ip>:9030 to bind to. Send HUP to the relay.

May 01 21:33:59.803 [notice] Received reload signal (hup). Reloading config and resetting internal state.
May 01 21:33:59.805 [notice] Closing no-longer-configured Directory listener on 0.0.0.0:9030
May 01 21:33:59.805 [notice] Opening Directory listener on <specific ip>:9030
May 01 21:33:59.805 [warn] Could not bind to <specific ip>:9030: Address already in use. Is Tor already running?
May 01 21:33:59.805 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
May 01 21:33:59.805 [err] Reading config failed--see warnings above. For usage, try -h.
May 01 21:33:59.805 [warn] Restart failed (config error?). Exiting.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by nickm

I think this is a duplicate of bug #531 ?

comment:2 Changed 9 years ago by nickm

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.