Opened 5 years ago

Closed 5 years ago

#13824 closed defect (not a bug)

build failed in onionoo

Reported by: madjack Owned by:
Priority: Low Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While building onionoo as per INSTALL documentation, it seems to failed with this :

/srv/onionoo/build.xml:70: The following error occurred while executing this line:
java.io.FileNotFoundException: /srv/onionoo/deps/metrics-lib/build.xml (No such file or directory)

at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:146)
at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:278)
at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:393)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.Main.runBuild(Main.java:809)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

The box is Debian wheezy with Java and Ant versions as recommended in the INSTALL guide too. I have also verified the jar files and there were installed. I do apologize if I'm missing something fundamental here.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by karsten

Status: newneeds_information

Sounds like you didn't run git submodule init && git submodule update before building Onionoo. Also take a look at CONTRIB.md for more details. Can you try if that fixes the problem?

And no worries about asking. The documentation could be much better here. (Want to submit a patch once you got it working?)

comment:2 Changed 5 years ago by iwakeh

This problem will go away with the first release of metrics-lib (cf. #13166).

comment:3 Changed 5 years ago by karsten

Resolution: not a bug
Status: needs_informationclosed

Assuming my suggestion above fixed the problem. Let's close this ticket and work on #13166 to avoid this problem in the future.

Note: See TracTickets for help on using tickets.