Opened 5 years ago

Closed 5 years ago

#13868 closed enhancement (not a bug)

enhancement request : display stats about ORCONN connections

Reported by: toralf Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version: Tor: 0.2.5.10
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While still wondering about the culprit of bug #13603 /me wonders if it would makes sense to see some stats about such errors in arm.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by atagar

From an interface perspective what did you have in mind?

comment:2 Changed 5 years ago by toralf

Well, it would be helpful to see, if an AS / a tor family / a particular network segment would be affected. But thinking about this longer this would mean to define a time frame over such a stats ... hhm, not easy to implement, or ?

Therefore me wonders if it would be a better idea to just print those info out to a CSV file and let the admin play with the raw data using its favorite tool?

comment:3 Changed 5 years ago by atagar

Sounds like something for a standalone script rather than integrated with arm, yes? If this is a commonly useful feature great, but what you're describing sounds pretty specific and not like something the vast majority of relay operators would find useful.

comment:4 Changed 5 years ago by toralf

yep - (it was easy to claim such a request, but thinking more about that topic now it seems that a separate script, which uses stem, would be the solution) ...

comment:5 Changed 5 years ago by atagar

Resolution: not a bug
Status: newclosed

Sounds great. Feel free to reopen if you'd like to discuss this further, and if you post the script somewhere please shoot me a link and I'll add it to the Stem examples page.

Note: See TracTickets for help on using tickets.