Opened 5 years ago

Closed 4 years ago

#13889 closed enhancement (duplicate)

Tor Browser software updater should link to announcement

Reported by: runa Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability
Cc: brade Actual Points:
Parent ID: #13512 Points:
Reviewer: Sponsor:

Description

The "View more information about this update"-link displayed by the Tor Browser software updater when a new update is available currently links to https://www.torproject.org/projects/torbrowser.html.en. If possible, it would be great to see this link to a page that actually does contain information about the latest update, such as an announcement email or blog post.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by mcs

Keywords: tbb-usability added

comment:2 Changed 4 years ago by mcs

Cc: brade added
Owner: changed from tbb-team to mcs
Parent ID: #13512
Status: newassigned

comment:3 Changed 4 years ago by gk

Resolution: duplicate
Status: assignedclosed

Marking this as duplicate of #13512 where the work got done.

Note: See TracTickets for help on using tickets.