Opened 5 years ago

Closed 3 years ago

#13894 closed defect (fixed)

Bugs in implementation of captcha system for trac.torproject.org

Reported by: Nicolas_Raoul Owned by: qbi
Priority: High Milestone:
Component: Internal Services/Service - trac Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by qbi)

Steps to reproduce:

  1. Fill the register dialog, to create a new account. No captcha visible. Press Submit
  2. Captcha error dialog appears, with a captcha question just below. Guess the captcha and press Enter
  3. Step 2 gets repeated indefinitely

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by gok

I just registered and also witnessed steps 1 and 2.
However, once I filled the captcha in step 2, the captcha error dialog did not reappear and the registration process ended correctly.

comment:2 Changed 4 years ago by qbi

Description: modified (diff)
Owner: set to qbi
Status: newassigned

Ticket #16379 is a duplicate of this one. Further discussion should happen here.

comment:3 Changed 4 years ago by huertanix

Severity: Normal

Where is the git repo for trac.torproject.org? I'm interested in helping take a look at the problem.

comment:4 Changed 3 years ago by qbi

Resolution: fixed
Status: assignedclosed

Captchas are currently disabled.

Note: See TracTickets for help on using tickets.