Opened 5 years ago

Closed 5 years ago

#13935 closed defect (fixed)

Issue with HS availability

Reported by: dgoulet Owned by: nickm
Priority: Medium Milestone:
Component: Core Tor/Chutney Version: Tor: 0.2.6.1-alpha
Severity: Keywords:
Cc: teor, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It takes around 40 to 45 seconds for a client of the chutney network to be able to reach an hidden service.

My first guest would be to look at the upload period of the HS descriptor. I can see in the logs that the HSDir simply doesn't have the descriptor when the client is trying to fetch it.

This can be reproduced by using the "patch" in #13934

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by teor

Version: Tor: 0.2.6.1-alpha

The changes to tor and chutney in #13718 may have fixed this - minimal and bridge chutney/tor networks can now bootstrap in as little as 10 seconds with the right torrc options.

Bugs: #13718, #13814, maybe #13787, #13839, #13924, #13823, #13929, #13963
Branch: bug13718-fast-bootstrap
Note: There are 5 branches that start with bug13718, please choose the right one.
Repository: ​​​​​​​​https://github.com/teor2345/tor.git

Bugs: #13823
Branch: bug13823-fast-bootstrap
Repository: ​​​​​​​​https://github.com/teor2345/chutney.git

Please test and post your results here or to #13718.

You'll need to edit your torrc templates to include some new options - they're in the chutney patch.

comment:2 Changed 5 years ago by teor

Parent ID: #13718

Track with other children of #13718

comment:3 Changed 5 years ago by teor

Status: newneeds_review

The draft changes in #13718 have been tested by dgoulet and myself, and bootstrap a network containing a hidden service in around 10 seconds.

But chutney needs to create the hidden service directory.
This branch makes it happen.

Bugs: #13935, #14019
Branch: bug13935-create-hs-directory
Repository: ​​​​​​​​​https://github.com/teor2345/chutney.git

comment:4 Changed 5 years ago by teor

Cc: nickm added
Parent ID: #13718

Hi Nick,

This patch makes chutney create a directory for hidden services.

Once it's merged, the fixes in #13718 resolve this issue as well.

comment:5 Changed 5 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Looks like I just want to cherry-pick d8be5e3436e994ba682bc2dbbccbf7b3c45c6bd0 .

(Done.)

Note: See TracTickets for help on using tickets.