Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13945 closed defect (duplicate)

constant micodesc erros over >= 2 days

Reported by: eli Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.21
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello - For at leat two days tor/vidalia been giving error notices. The last three showing up in the vidalia Message Log (Basic) are:

[Thu Dec 11 11:22:21 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_clean(): Bug: [0]: ID=93F1DD316F1044B2A173F21CF6D084F0DDBCF62E. md=025FBA98, rs=05F3C668, ri=043CF998. Microdesc digest in RS does match. RS okay in networkstatus.
"
[Thu Dec 11 11:22:21 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_clean(): Bug: Microdescriptor seemed very old (last listed 168 hours ago vs 168 hour cutoff), but is still marked as being held by 1 node(s). I found 1 node(s) holding it. Current networkstatus is 1 hours old. Hashtable badness is 0.
"
[Thu Dec 11 11:22:21 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_cache_clean(): Bug: [0]: ID=2BC1C6359F2B4411DA277385F58582D04B4DDA34. md=0254B390, rs=0337A960, ri=04273D40. Microdesc digest in RS does match. RS okay in networkstatus.
"

The Message Log (Advanced) tab shows:

Dec 11 11:22:21.459 [Warning] microdesc_cache_clean(): Bug: [0]: ID=93F1DD316F1044B2A173F21CF6D084F0DDBCF62E. md=025FBA98, rs=05F3C668, ri=043CF998. Microdesc digest in RS does match. RS okay in networkstatus.
Dec 11 11:22:21.474 [Warning] microdesc_cache_clean(): Bug: Microdescriptor seemed very old (last listed 168 hours ago vs 168 hour cutoff), but is still marked as being held by 1 node(s). I found 1 node(s) holding it. Current networkstatus is 1 hours old. Hashtable badness is 0.
Dec 11 11:22:21.474 [Warning] microdesc_cache_clean(): Bug: [0]: ID=2BC1C6359F2B4411DA277385F58582D04B4DDA34. md=0254B390, rs=0337A960, ri=04273D40. Microdesc digest in RS does match. RS okay in networkstatus.
Dec 11 12:15:38.112 [Notice] Heartbeat: Tor's uptime is 7 days 17:50 hours, with 11 circuits open. I've sent 10.01 GB and received 10.04 GB.

At the same time (as can be seen from the last line above) the bridge is working fine & carrying a lot of traffic. Globe does show a periodicity in traffic that may reflect these errors; I'm not sure if the errors inhibit traffic or not.

I can supply complete logs for the past two days if you need them. HTH eliaz

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by jantor

The same happened to me:Tor 0.2.5.12 (git-3731dd5c3071dcba) on Linux Mint 17.1.,after a couple of days running tor relay. Tor restart clear messages, but they coming back after few days.

comment:2 Changed 5 years ago by cypherpunks

Component: VidaliaTor

comment:3 Changed 5 years ago by cypherpunks

Duplicate of #7164

comment:4 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

comment:5 in reply to:  1 Changed 5 years ago by cypherpunks

Replying to jantor:

The same happened to me:Tor 0.2.5.12 (git-3731dd5c3071dcba) on Linux Mint 17.1.,after a couple of days running tor relay. Tor restart clear messages, but they coming back after few days.

Can you test relay with UseMicrodescriptors option? add it to torrc:

UseMicrodescriptors 0

Used by we_use_microdescriptors_for_circuits() which should to return 0 anyway if your relay never ran with ClientOnly option or something that breaking server move.

Note: See TracTickets for help on using tickets.