Opened 3 years ago

Closed 3 years ago

#13982 closed defect (fixed)

TorBirdy crashes if tor process not running in Windows 8

Reported by: saint Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: sukhe, saint Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

(report of a friend's issue - most recent Thunderbird and TorBirdy on Windows 8)

So in Windows 8, if one starts Thunderbird when the tor process is not already running, it will crash.

Possible solutions:

  • add a note in the top line of the extension description stating that TorBirdy requires tor browser to be running before starting Thunderbird. (This is in the documentation, but was overlooked in this case).
  • fail gracefully with a popup that says that messages will not be sent over the Tor network until starting the tor process and restarting thunderbird.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by ioerror

This sounds like a bug in Thunderbird itself. If you uninstall TorBirdy and then set a SOCKS proxy that isn't there - what happens?

comment:2 in reply to:  description Changed 3 years ago by sukhbir

Replying to saint:

(report of a friend's issue - most recent Thunderbird and TorBirdy on Windows 8)

So in Windows 8, if one starts Thunderbird when the tor process is not already running, it will crash.

Possible solutions:

  • add a note in the top line of the extension description stating that TorBirdy requires tor browser to be running before starting Thunderbird. (This is in the documentation, but was overlooked in this case).
  • fail gracefully with a popup that says that messages will not be sent over the Tor network until starting the tor process and restarting thunderbird.

Jake has already commented -- this looks like some other issue. If you start Thunderbird (with TorBirdy) and Tor is not running, Thunderbird will just complain about the proxy and that's it. There is no crash or anything of that sort.

Can you ask your friend to try it after uninstalling TorBirdy? :)

comment:3 Changed 3 years ago by saint

Jeff says "Doesn't work even with Tor running." Instead it just crashes entirely. And Thunderbird ran fine immediately before installing TorBirdy.

Last edited 3 years ago by saint (previous) (diff)

comment:4 in reply to:  3 Changed 3 years ago by sukhbir

Replying to saint:

Jeff says "Doesn't work even with Tor running." Instead it just crashes entirely. And Thunderbird ran fine immediately before installing TorBirdy.

So far, I have not been able to reproduce this so I will try with whatever information we have: did Jeff update TorBirdy or did he do a clean install?

comment:5 Changed 3 years ago by sukhbir

Resolution: fixed
Status: newclosed

Fixed with TorBirdy 0.1.4. Please upgrade!

Note: See TracTickets for help on using tickets.