Opened 4 years ago

Closed 3 years ago

#14054 closed defect (fixed)

HTTPS Everywhere Prevents Steam Site From Working As Intended

Reported by: CoolPrizes Owned by:
Priority: Very High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For Steam sites, such as steamcommunity.com, having Akamai enabled in HTTPS-Everywhere prevents the site from working as intended.

Example: http://steamcommunity.com/profiles/76561197960265729/

Next to the name "rich" there is an arrow to see his previous names. With Akamai HTTPS enabled, it does not show up. With it disabled, it shows up.

Another example: http://steamcommunity.com/sharedfiles/filedetails/?id=194005009

With Akamai enabled in HTTPS-Everywhere, images don't show up, and site interactivity is off. With Akamai disabled, it's working again.

It does work if I visit the https version of the Steam sites.

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by mrtino

Hi,
do you also use NoScript ?

NoScript disable by default all javascript code. Akamai is blocked. If you have NoScript, see if you have enabled AkamaiHD.net

comment:2 Changed 3 years ago by fuglede

Resolution: fixed
Severity: Normal
Status: newclosed

It looks like this one fixed itself; the arrow now appears both with and without the Akamai ruleset being active. Closing as such.

Note: See TracTickets for help on using tickets.