Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14064 closed enhancement (fixed)

Bridge IP + ID wrapping weirdness

Reported by: breadtk Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: bridgedb-reportbug, bridgedb-0.2.4, isis2014Q3Q4
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Link in question: https://bridges.torproject.org/bridges?transport=obfs3

When bridge's IP addresses and IDs are put on the webpage there is a weird wrapping that occurs on screen. This is a minor usability issue when somebody wants to copy/paste the bridge information or try to read it.

Specifically this occurs when you request bridges with a pluggable transport. The easiest fix for this would be to change the padding size from 20px to 10px in div.bridge-lines in your CSS files. This won't solve the usability issue with all pluggable transport with a long name (e.g. scramblesuit)

Thank you for your consideration.

Child Tickets

Attachments (1)

TICKET-14064-bridgedb-wrapping.png (113.3 KB) - added by isis 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by breadtk

Type: defectenhancement

comment:2 Changed 5 years ago by isis

Possible duplicate of #12664.

Changed 5 years ago by isis

comment:3 Changed 5 years ago by isis

Fixed in my fix/14064-bridgeline-wrapping_r2 branch by adding a horizontal scrollbar if the bridge lines are too long:

https://trac.torproject.org/projects/tor/raw-attachment/ticket/14064/TICKET-14064-bridgedb-wrapping.png

comment:4 Changed 5 years ago by isis

Resolution: fixed
Status: newclosed

Merged into develop for 0.2.4 release.

Last edited 5 years ago by isis (previous) (diff)

comment:5 Changed 5 years ago by isis

Keywords: bridgedb-0.2.4 added

comment:6 Changed 5 years ago by isis

Keywords: Isis2014Q3Q4 added

comment:7 Changed 5 years ago by isis

Keywords: isis2014Q3Q4 added; Isis2014Q3Q4 removed
Note: See TracTickets for help on using tickets.