Opened 5 years ago

Closed 4 years ago

#14068 closed defect (not a bug)

Unecessary line in tor-spec.txt

Reported by: Aaron1011 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-spec
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Section 4.1 of tor-spec.txt contains the following line:

When the "in-protocol" handshake is

used, implementations MUST NOT list any version before 3, and SHOULD
list at least version 3.

tTe spec states that implementations SHOULD use at least version three, indicating that they may choose to do othereise. However, this is made redundant by the previous clause of the sentence, which states that any version below three MUST NOT be used.

Using SHOULD implies that another option is available, when in reality no other choice is possible, without breaking the MUST NOT clause.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by Aaron1011

Summary: Necessary line in tor-spec.txtUnecessary line in tor-spec.txt

comment:2 Changed 5 years ago by nickm

But other versions _are_ available; version 4, for example.

comment:3 Changed 4 years ago by nickm

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.