Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14099 closed defect (fixed)

Thunderbird hangs at restart after install of TorBirdy 0.1.3

Reported by: Ricard Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: ter.one.leeboi@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Thunderbird 31.3.0 at
Win7 and FreeBSD10.1

FreeBSD:
GLib-CRITICAL : g_slice_set_config: assertion 'sys_page_size == 0' failed

Child Tickets

Change History (20)

comment:1 Changed 3 years ago by leeroy

Cc: ter.one.leeboi@… added

comment:2 Changed 3 years ago by cypherpunks

In the case some friends of mine are investigating right now, this seems to be related to Thunderbird/TorBirdy trying to open a Drafts folder that does not exist, but insisting on it, so it enters an infinite loop.

There might be a difference between "Setting up the IMAP account and then installing TorBirdy" and "Installing TorBirdy and then setting up the IMAP account".

comment:3 in reply to:  2 Changed 3 years ago by sukhbir

Replying to cypherpunks:

In the case some friends of mine are investigating right now, this seems to be related to Thunderbird/TorBirdy trying to open a Drafts folder that does not exist, but insisting on it, so it enters an infinite loop.

There might be a difference between "Setting up the IMAP account and then installing TorBirdy" and "Installing TorBirdy and then setting up the IMAP account".

Thanks! I can now reproduce the issue but still have to pin down the exact line in the code. (I will update this ticket as soon as I have something.)

comment:5 Changed 3 years ago by cypherpunks

Sweet! Progress! Thanks to anon and sukhbir!!! :)

I have been having this problem, and indeed, I have 3 IMAP accounts (as well as 3 POP accounts).

Is there anything this non-tech person can do to help you?

Thanks!!!!

Last edited 3 years ago by cypherpunks (previous) (diff)

comment:6 in reply to:  5 Changed 3 years ago by sukhbir

Replying to cypherpunks:

Sweet! Progress! Thanks to anon and sukhbir!!! :)

I have been having this problem, and indeed, I have 3 IMAP accounts (as well as 3 POP accounts).

Thanks for letting us know!

Is there anything this non-tech person can do to help you?

Thanks!!!!

Make a new profile (thunderbird -p), create less than three IMAP accounts, install TorBirdy and see if it works. It should.

I will post more details later when we confirm the fix.

comment:7 Changed 3 years ago by fkbeoxlxet

Not sure my experience relates to this issue or not.

My TB suddenly refused to start up a couple days ago. I have been using TB + Torbirdy for long time. A couple of days ago I upgraded an extension Provider for Google Calendar from 1.0.3 to 1.0.4. After that I couldn't start up TB. I noticed that its memory usage keeps going up but no front-end was shown. I had to manually kill the process finally. If I disable Torbirdy (in safe mode) then TB happily starts up.

OS: MacOSX 10.10.2
TB: 31.5.0
# of IMAP account: 4
# of POP account: 0
TB extensions: Adblock Plus, Calendar Tweaks, Display Contact Photo, Enigmail, Lightning, Provider for Google Calendar, Torbirdy

comment:8 in reply to:  7 Changed 3 years ago by sukhbir

Replying to fkbeoxlxet:

Not sure my experience relates to this issue or not.

My TB suddenly refused to start up a couple days ago. I have been using TB + Torbirdy for long time. A couple of days ago I upgraded an extension Provider for Google Calendar from 1.0.3 to 1.0.4. After that I couldn't start up TB. I noticed that its memory usage keeps going up but no front-end was shown. I had to manually kill the process finally. If I disable Torbirdy (in safe mode) then TB happily starts up.

OS: MacOSX 10.10.2
TB: 31.5.0
# of IMAP account: 4
# of POP account: 0
TB extensions: Adblock Plus, Calendar Tweaks, Display Contact Photo, Enigmail, Lightning, Provider for Google Calendar, Torbirdy

You mentioned you updated Provider for Google Calendar. During this period or afterwards, did you also upgrade TorBirdy to 0.1.3?

The four IMAP accounts you have may be the issue since that is common to other users who have reported this problem. And saving drafts for IMAP accounts -- which is what is causing the error -- was introduced in TorBirdy 0.1.3.

comment:9 Changed 3 years ago by leeroy

@fkbeoxlxet If you don't mind could you try something. Open TB in safe mode and select the menu->help->troubleshooting information->open directory

Make a backup of the Mail folder somewhere else then open it. Delete the Drafts and Drafts.msf from Local Folders. Delete all other .msf files from all folders under Mail. Then try loading TB as usual.

comment:10 Changed 3 years ago by fkbeoxlxet

Firstly, I apology for some wrong figures. I have 13 imap accounts!

5 of them are real accounts in the sense that TB retrieves messages from them periodically.

8 of them are dummy accounts which TB never retrieve message from. They are just for sending out messages.

@sukhbir, I only updated Provider for Google Calendar. No other extension or email account settings were updated.

As said, I've been using Torbirdy for a long time. The imap accounts also exist for long time. I doubt whether the current issue really caused by having more than 3 imap accounts.

@leeroy, below is the experiment I just carried out per your suggestion:

  1. Quit TB.
  2. Delete "draft*.*" in profile folder tree.
  3. Enter TB safe mode, enable Torbirdy. Quit.
  4. Again, delete "draft*.*" in profile folder tree. (Safe mode re-created the files.)
  5. Start TB, failed. Kill the process.
  6. Delete "draft*.*" in profile folder tree. Delete ".msf" in profile/Mail folder tree.
  7. Start TB, failed. Kill the process.
  8. Enter TB safe mode, delete all mail accounts until only 1 imap account left. Quit.
  9. Delete "draft*.*" in profile folder tree. Delete ".msf" in profile/Mail folder tree.
  10. Start TB, successful.
  11. Add 2nd imap account. Get all new messages. Successful. Quit.
  12. Delete "draft*.*" in profile folder tree. Delete ".msf" in profile/Mail folder tree.
  13. Start TB, successful.
  14. Add 3rd imap account. Get all new messages. Successful. Quit.
  15. Delete "draft*.*" in profile folder tree. Delete ".msf" in profile/Mail folder tree.
  16. Start TB, successful.
  17. Add 4th imap account. Get all new messages. Successful. Quit.
  18. Delete "draft*.*" in profile folder tree. Delete ".msf" in profile/Mail folder tree.
  19. Start TB, successful. Quit.
  20. Start TB, successful. (Not deleting any file before starting.)

By the result of step 19 and 20 I conclude that TB + Torbirdy can survive with more than 3 imap accounts.

Please let me know if there is anything I can help. I will keep my experimental profile folder in case you want further experiments with it.

comment:11 Changed 3 years ago by leeroy

Wow, thanks. I'd like to propose another test using the failing profile. Could you try deleting just the ImapMail folder from the failing profile then try loading TB. This will leave all IMAP accounts intact, including unsent drafts, but will force TB to resync all local data against the mail server perspective. Your testing has eliminated index corruption of local data. It would be great to eliminate the worst case scenario of corrupted mbox data. Thank-you!

Last edited 3 years ago by leeroy (previous) (diff)

comment:12 Changed 3 years ago by fkbeoxlxet

@leeroy, thanks for your suggestion and this is what I did:

  1. Quit TB.
  2. In TB safe mode, enable Torbirdy, quit.
  3. Delete IMapMail folder.
  4. Start TB, failed. Kill the process.
  5. In TB safe mode, disable Torbirdy, quit.
  6. Start TB, , successful. Quit.
  7. In TB safe mode, enable Torbirdy, quit.
  8. Start TB, failed. Kill the process.

I think up to this point is what you asked me to do. Out of personal curiosity I continue the experiment....

  1. In TB safe mode, disable all extensions except Torbirdy, quit.
  2. Start TB, failed. Kill the process.

At this point it seems that the issue doesn't nothing with other extensions. Does it really caused by the number of accounts? I continue....

  1. In TB safe mode, delete the 8 dummy accounts, quit.
  2. Start TB, failed. Kill the process.
  3. In TB safe mode, delete 1 imap account (now 4 left).
  4. Start TB, failed. Kill the process.
  5. In TB safe mode, delete 1 imap account (now 3 left).
  6. Start TB, failed. Kill the process.
  7. In TB safe mode, delete 1 imap account (now 2 left).
  8. Start TB, successful.

Oh god, number does matter! But why TB can survive with 3 and more imap accounts in the first experiment but not in this experiment? I keep experimenting....

  1. Enable all extensions. Quit.
  2. Start TB, successful.

Again, confirmed that other extensions are not the culprit. Number really matter?

  1. Add 1 imap account (3 totally), quit.
  2. Start TB, successful, add 1 imap account (4 totally), quit.
  3. Start TB, successful.

It seems to me that:

  1. If initially there are 3 or more imap accounts, and enable Torbirdy, TB cannot start.
  2. If initially there are less than 3 imap accounts, and enable Torbirdy, more than 3 imap accounts can be added afterward.

Maybe I can do a couple more experiments to confirm them later. Please let me know if you have any suggestion. Too tire to do any more now. (It is almost 5am in my city).

comment:13 Changed 3 years ago by Ricard

Same behaviour here:
TB with 1 imap account : Success
TB with 2 imap accounts: Success
TB with 3 imap accounts: Fail

comment:14 Changed 3 years ago by leeroy

I see a bug in torbirdy.js at lines 512 and 531. The var declaration at 531 reuses 'i' which messes up the enumeration of the outer loop at 512.

comment:15 in reply to:  14 Changed 3 years ago by sukhbir

Replying to leeroy:

I see a bug in torbirdy.js at lines 512 and 531. The var declaration at 531 reuses 'i' which messes up the enumeration of the outer loop at 512.

You got that right, that is exactly the issue. I think it's clear that this is what is causing the bug and we will release an update by tomorrow.

comment:16 Changed 3 years ago by leeroy

Hi sukhbir, it's curious that the other tickets describe the problem occurring after install at later dates. I see disabling the addon resets the first-run condition so maybe that contributes. If you could describe the steps to reproducing the hanging I would be happy to test further.

comment:17 Changed 3 years ago by sukhbir

Resolution: fixed
Status: newclosed

Fixed with TorBirdy 0.1.4. Please upgrade!

comment:18 in reply to:  16 Changed 3 years ago by sukhbir

Replying to leeroy:

Hi sukhbir, it's curious that the other tickets describe the problem occurring after install at later dates. I see disabling the addon resets the first-run condition so maybe that contributes. If you could describe the steps to reproducing the hanging I would be happy to test further.

Hi leeroy. You are right about disabling the add-on resets the condition so maybe that could have been the issue. Give 0.1.4 a run and let us know how it works?

comment:19 Changed 3 years ago by leeroy

Will do sukhbir! (Disregard previous bit--should not review code past bedtime)

I've noticed the following problems:
a) if a user exits from the first-time account setup wizard and tries to add the accounts using the menu the details don't populate the frame and so cannot be properly configured manually
b) the account creation wizard disables automatic detection of settings (for privacy) but then leaves the user of TorBirdy on their own to notice setting up smtp properly (which isn't immediately apparent)
I'll perform further testing with the latest version before proceeding. Thanks!

Last edited 3 years ago by leeroy (previous) (diff)

comment:20 in reply to:  19 Changed 3 years ago by sukhbir

Replying to leeroy:

Will do sukhbir! (Disregard previous bit--should not review code past bedtime)

I've noticed the following problems:
a) if a user exits from the first-time account setup wizard and tries to add the accounts using the menu the details don't populate the frame and so cannot be properly configured manually

By the "first-time account setup", do you mean the account wizard that is shown the first time after TorBirdy is installed?

b) the account creation wizard disables automatic detection of settings (for privacy) but then leaves the user of TorBirdy on their own to notice setting up smtp properly (which isn't immediately apparent)

Yeah we are aware of this and I agree, but then until Thunderbird fixes the leaks in the auto-configuration wizard, I guess it's better that a user has problems configuring their account as compared to leaking personal information...

(I tried to address some of these concerns in the documentation)

Note: See TracTickets for help on using tickets.