Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#14100 closed enhancement (fixed)

Toggle NetworkSettings menuitem visibility based on an environment variable

Reported by: linostar Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, tbb-torbutton, GeorgKoppen201501, tbb-4.5-alpha-3
Cc: proper, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is a feature requested by some linux distros, where the "Open Network Settings..." menuitem in TorButton is unneeded. A patch is to be made so this menuitem becomes hidden if a certain environment variable is set.

Child Tickets

Change History (15)

comment:1 Changed 5 years ago by linostar

Status: newneeds_review

I made a patch that implement the solution described in the first post:

https://github.com/linostar/torbutton/commit/92d2ee890004baddf5d4da39664ed1ba14c665d2

comment:2 Changed 5 years ago by proper

Component: TorbuttonTor Browser

comment:3 Changed 5 years ago by proper

Patch was also tested by me and worked fine. Thanks linostar!

comment:4 Changed 5 years ago by linostar

The older patch link is now obsolete. I made a small alteration to make the code cover all logical cases.

New patch:
https://github.com/linostar/torbutton/commit/d33d7c7d7c74b7140240e6e1d17d72ae3808a6c3

comment:5 Changed 5 years ago by mcs

Cc: brade added
Keywords: tbb-usability tbb-torbutton TorBrowserTeam201501R added
Owner: set to mcs
Status: needs_reviewassigned

comment:6 Changed 5 years ago by mcs

Status: assignedneeds_review

comment:7 Changed 5 years ago by gk

In which scenario is it a feature to prevent the user from switching to a pluggable transport easily from within the browser itself in case she just get blocked in some country?

comment:8 in reply to:  7 Changed 5 years ago by proper

Replying to gk:

In which scenario is it a feature to prevent the user from switching to a pluggable transport easily from within the browser itself in case she just get blocked in some country?

In any scenario, where Tor runs on a different system than the browser. Such as Whonix, where Tor is running on Whonix-Gateway, while Tor Browser is running in Whonix-Workstation. Or on systems, where the browser is by design not supposed to configure Tor/pluggable transports. Such as Tails, if I understand that right. They use tor-launcher in standalone mode and not the let user configure Tor/pluggable transports within the browser.

For easily configuring pluggable transports in such cases, we have in something else in mind:
#14121: make TBB usable as "system Tor"

comment:9 Changed 5 years ago by gk

Just checking for the existence of the env variable should be enough. Could you adapt the patch accordingly?

comment:10 in reply to:  9 Changed 5 years ago by linostar

Replying to gk:

Just checking for the existence of the env variable should be enough. Could you adapt the patch accordingly?

Sure. Here you go:
https://github.com/linostar/torbutton/commit/748cb437c1189ed0ad4b65f69e9c0ac06c4a1914

comment:11 Changed 5 years ago by gk

Keywords: tbb-4.5-alpha-3 added

comment:12 Changed 5 years ago by gk

Keywords: GeorgKoppen201501R added; TorBrowserTeam201501R removed

comment:13 Changed 5 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Added as commit 765fee607af6fa88b99476dee10298e5db3b9eb1. I had to tweak the commit message a bit and removed the superfluous newline/whitespace. Thanks.

comment:14 Changed 5 years ago by gk

Keywords: GeorgKoppen201501 added; GeorgKoppen201501R removed

comment:15 Changed 4 years ago by proper

Severity: Normal

I called #10632 a duplicate.

Note: See TracTickets for help on using tickets.