Opened 4 years ago

Closed 4 years ago

#14147 closed defect (wontfix)

The rpm-based linux distribution installation instruction is outdated

Reported by: xuhdev Owned by: Sebastian
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This page (https://www.torproject.org/docs/rpms.html.en) instructs people to use a repository made by tor project and claims that there is a name clash epel. However, I tried with epel 7, there is the tor which means the tor we are talking about here. Which means, tor is in epel and it's not a name clash.

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by xuhdev

Component: - Select a componentWebsite
Owner: set to Sebastian

comment:2 Changed 4 years ago by Sebastian

I'm not sure I understand. If there is a tor package in epel 7, that means there is a name clash, right?

comment:3 Changed 4 years ago by hiviah

To clarify: there's a package named "tor" in epel repository that is different than tor package from the repo listed in https://www.torproject.org/docs/rpms.html.en.

If you enable both, it may sometimes happen that due to specver number (the "revision" number of rpm package, it's the one after dash) the epel's package may install over package from tor repo. The issue is that for instance epel's package runs under different user than our package - but the files in /var/ have remained under the old user's ownership (the files that are not packaged but created by Tor instance running). This results in the package unable to run properly. There are other configuration differences as well.

Whatever you choose just stick with the same source for the package.

comment:4 Changed 4 years ago by Sebastian

Resolution: wontfix
Status: newclosed

Closing as won't fix. Please reopen with suggested better wording if it exists.

Note: See TracTickets for help on using tickets.