Opened 5 years ago

Closed 4 years ago

#14156 closed defect (fixed)

Tor Browser: Unsolved DNS of a website or HS result in 100% CPU usage

Reported by: Sasi Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version: Tor: 0.2.5.10
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've been observing this behavior for a while. Tor browser taking 100% CPU for few seconds if it DNS resolver fails for a website and HS is not reachable.

[Sasi@NoNameForHost ~]# pstack 19469
Thread 1 (process 19469):
#0 0x00007f05b44b071d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f05b56ace60 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#2 0x00007f05b0b16346 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#3 0x00007f05b0b167d4 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#4 0x00007f05b0b16bb8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#5 0x00007f05b0ae4e95 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#6 0x00007f05b0aa12f2 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#7 0x00007f05b0c5de74 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#8 0x00007f05b0c442eb in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#9 0x00007f05b0ae57e1 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#10 0x00007f05b56aeff8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#11 0x00007f05b53c6ee5 in start_thread (arg=0x7f05997ff700) at pthread_create.c:309
#12 0x00007f05b44bab8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
[Sasi@NoNameForHost ~]# pstack 19469
Thread 1 (process 19469):
#0 0x00007f05b44b071d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f05b56ace60 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#2 0x00007f05b0b16346 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#3 0x00007f05b0b167d4 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#4 0x00007f05b0b16bb8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#5 0x00007f05b0ae4e95 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#6 0x00007f05b0aa12f2 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#7 0x00007f05b0c5de74 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#8 0x00007f05b0c442eb in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#9 0x00007f05b0ae57e1 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#10 0x00007f05b56aeff8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#11 0x00007f05b53c6ee5 in start_thread (arg=0x7f05997ff700) at pthread_create.c:309
#12 0x00007f05b44bab8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
[Sasi@NoNameForHost ~]# pstack 19469
Thread 1 (process 19469):
#0 0x00007f05b53cdb8b in libc_recv (fd=71, buf=0x7f057a040f20, n=5, flags=-1) at ../sysdeps/unix/sysv/linux/x86_64/recv.c:33
#1 0x00007f05b56abf36 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#2 0x00007f05b0b5cb61 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#3 0x00007f05b0b5ccec in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#4 0x00007f05b0b5cd47 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#5 0x00007f05b0b14426 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#6 0x00007f05b0b16899 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#7 0x00007f05b0b16bb8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#8 0x00007f05b0ae4e95 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#9 0x00007f05b0aa12f2 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#10 0x00007f05b0c5de74 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#11 0x00007f05b0c442eb in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#12 0x00007f05b0ae57e1 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#13 0x00007f05b56aeff8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#14 0x00007f05b53c6ee5 in start_thread (arg=0x7f05997ff700) at pthread_create.c:309
#15 0x00007f05b44bab8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
[root@NoNameForHost Downloads]# pstack 19469
Thread 1 (process 19469):
#0 0x00007f05b44b071d in poll () at ../sysdeps/unix/syscall-template.S:81
#1 0x00007f05b56ace60 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#2 0x00007f05b0b16346 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#3 0x00007f05b0b167d4 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#4 0x00007f05b0b16bb8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#5 0x00007f05b0ae4e95 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#6 0x00007f05b0aa12f2 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#7 0x00007f05b0c5de74 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#8 0x00007f05b0c442eb in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#9 0x00007f05b0ae57e1 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libxul.so
#10 0x00007f05b56aeff8 in ?? () from /home/Sasi/tor-browser_en-US/Browser/libnspr4.so
#11 0x00007f05b53c6ee5 in start_thread (arg=0x7f05997ff700) at pthread_create.c:309
#12 0x00007f05b44bab8d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Child Tickets

Attachments (1)

tor_browser_dns_unrsolved.png (189.7 KB) - added by Sasi 5 years ago.
100% CPU usage thread

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by Sasi

100% CPU usage thread

comment:1 Changed 4 years ago by cypherpunks

Severity: Normal

This is a duplicate of #9659.

comment:2 Changed 4 years ago by teor

Resolution: fixed
Status: newclosed

Please reopen if the issue reoccurs.

Note: See TracTickets for help on using tickets.