Opened 5 years ago

Closed 3 years ago

#14225 closed defect (wontfix)

torweather subscription email has links in wrong order

Reported by: kyrtor Owned by:
Priority: Medium Milestone:
Component: Metrics/Tor Weather Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Preferences and Unsubscribe are mixed.

Dear human,

[..]

You can change your Tor Weather notification preferences here:

https://weather.torproject.org/unsubscribe/ycn3......

or unsubscribe from these reports at any time by visiting the following url:

https://weather.torproject.org/preferences/Aho.....

Child Tickets

Attachments (1)

0001-Fix-email-unsubscribe-preference-order.patch (812 bytes) - added by thexa4 5 years ago.
Patch that fixes the problem

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by creo

I second that. Its rather confusing ...

if you click on the "change your preferences" link, you are being unsubscribed,
while clicking on the unsubscribe link leads you to your preferences (where you btw. cannot unsubscribe :P)

comment:2 Changed 5 years ago by creo

btw: this is a dupe of #13918

comment:3 Changed 5 years ago by AndrewTheLott

Here's a screenshot to possibly clarify:

https://i.imgur.com/hXwgyav.png

Changed 5 years ago by thexa4

Patch that fixes the problem

comment:4 Changed 4 years ago by Michanek

I guess this problem was introduced when trying to solve the I-click-at the first-link-I see-without-reading-problem reported in #6616.

comment:5 Changed 3 years ago by karsten

Resolution: wontfix
Status: newclosed

Tor Weather has been discontinued as of May 24, 2016: https://lists.torproject.org/pipermail/tor-relays/2016-June/009424.html. Batch-closing all remaining tickets as announced in #19382. A list of these tickets and any other Weather tickets modified after June 26, 2016 will be available here: https://trac.torproject.org/projects/tor/query?changetime=Jun+27%2C+2016..&component=^Metrics%2FTor+Weather

Note: See TracTickets for help on using tickets.