Opened 5 years ago

Closed 5 years ago

#14255 closed task (wontfix)

Conduct periodic regression tests of nsTransferable selection caching

Reported by: michael Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: TorBrowserTeam201503
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To ensure correct operation of selection caching over time, implement automated tests validating requirements from #9701.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by arthuredelstein

Just in case it's a useful example, here's a mochitest-browser regression test in tor-browser.git for preventing the Permissions manager from writing to disk:
https://gitweb.torproject.org/tor-browser.git/commit/?h=tor-browser-31.4.0esr-4.5-1&id=bcabca0f90d3be3e1c0fc46b1320421f4c6debdd

comment:2 Changed 5 years ago by michael

Priority: minornormal

comment:3 Changed 5 years ago by michael

widget/nsITransferable.idl:

"Use of the SetIsPrivateData() method generated by isPrivateData attribute should be avoided as much as possible because the value set may not reflect the status of the context in which the transferable was created."

Does this indicate a problem that we can test for?

comment:4 Changed 5 years ago by michael

A chrome test (see widget/tests/test_bug1123480.xul) corresponding to this ticket was merged in the Mozilla trunk and will release in ESR38. It's likely that the effort to construct a separate Tor Browser test is better spent testing the upstreamed nsTransferable changes (and test) to the Mozilla trunk once ESR38 is released and merged to a Tor Browser release.

comment:5 Changed 5 years ago by michael

Resolution: wontfix
Status: newclosed

According to discussion on the TBB development meeting 23 February 2015, tests for the solution to #9701 are withheld. There are already tests in mozilla-trunk to be released in ESR38, which will likely be used for post April Tor Browser releases, rendering test integration to pre ESR38 Tor Browsers short lived.

Note: See TracTickets for help on using tickets.