Opened 5 years ago

Closed 5 years ago

#14263 closed defect (invalid)

Firefox reuses already running instance

Reported by: voyd Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi, I installed torbrowser using torbrowser-launcher on arch linux installed via aur.

Firefox is started by

TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox  --class "Tor Browser" \
-profile TorBrowser/Data/Browser/profile.default "${@}"

This tries to connect to a running instance of firefox first. If --new-instance is added, this could be avoided.

I don't know my way around firefox very well though, and I can't rule out any other communication. --no-remote should stop everything, but if I use that, firefox says

Error: argument -no-remote is invalid when argument -allow-remote is specified

so I assume that remote functionality is needed somewhere.

If this recommendation is not followed, there should probably be a warning instead of opening a new, insecure window on the already running firefox.

Possible duplicate of https://trac.torproject.org/projects/tor/ticket/11105
--allow-remote probably because of https://trac.torproject.org/projects/tor/ticket/12763

Maybe this needs some more work than just adding --new-instance.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by voyd

Also related: https://trac.torproject.org/projects/tor/ticket/2254 (can't open regular firefox when TBB is running. Seems to be the reason why --no-remote was originally introduced)

comment:2 Changed 5 years ago by mcs

Tor Browser does run with remoting disabled. But tor-launcher overrides that; see:
https://github.com/micahflee/torbrowser-launcher/commit/de134835a05b74e750da291e90fa86cfc43feae6

You will need to open an issue against tor-launcher, which (someone please correct me if I am wrong) is not an official Tor Project project. I assume they track their issues on GitHub.

comment:3 Changed 5 years ago by mcs

Resolution: invalid
Status: newclosed

Did you file an issue against tor-launcher for this? I am resolving this Tor Browser ticket as 'invalid'.

Note: See TracTickets for help on using tickets.