Opened 5 years ago

Closed 5 years ago

#14336 closed defect (fixed)

Disappearing Back/Next buttons on first Tor Launcher screen

Reported by: dcf Owned by: brade
Priority: Low Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords: TorBrowserTeam201502
Cc: lnl@…, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In the first screen of the first-start wizard, there are Back and Next buttons next to Exit. Back is disabled. If you click Next, it's like clicking Configure.

After clicking Next or Configure, if you then click Back, you arrive at the first screen again, but the Back/Next buttons are gone.

I'm guessing it's a bug that the Back/Next show up on the first screen, because Back doesn't make sense and Next is the same as Configure.

Child Tickets

Attachments (3)

1.png (30.0 KB) - added by dcf 5 years ago.
First screen on first run.
2.png (25.7 KB) - added by dcf 5 years ago.
Second screen, after clicking Next.
3.png (28.6 KB) - added by dcf 5 years ago.
First screen again, after clicking Back.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by dcf

Attachment: 1.png added

First screen on first run.

Changed 5 years ago by dcf

Attachment: 2.png added

Second screen, after clicking Next.

Changed 5 years ago by dcf

Attachment: 3.png added

First screen again, after clicking Back.

comment:1 Changed 5 years ago by dcf

Here's the first screen, with Back/Next buttons:
First screen on first run.
Then click Next:
Second screen, after clicking Next.
Then click Back:
First screen again, after clicking Back.

comment:2 in reply to:  description Changed 5 years ago by mcs

Replying to dcf:

I'm guessing it's a bug that the Back/Next show up on the first screen, because Back doesn't make sense and Next is the same as Configure.

Yes, that is the bug – the buttons are supposed to be hidden. They are hidden on Mac OS but not on Windows or Linux (I think). Within src/chrome/content/network-settings-wizard.xul, there is an onpageshow attribute on the first wizardpage element that is supposed to hide the buttons:

onpageshow="setTimeout(function() { showWizardNavButtons(false); }, 0);"

We will need to investigate. The fact that we already put a setTimout(..., 0) there leads me to guess that this bug might be caused by a timing issue (which could easily be platform-specific).

comment:3 Changed 5 years ago by mcs

Cc: mcs added

comment:4 Changed 5 years ago by mcs

Keywords: TorBrowserTeam201502 added
Resolution: fixed
Status: newclosed

This issue was fixed in conjunction some other minor code clean up we did for #13271.

Note: See TracTickets for help on using tickets.