Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#14423 closed enhancement (duplicate)

Prompt the user to confirm that in-progress downloads will be cancelled if the New Identity button is pressed.

Reported by: Rola Owned by:
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, tbb-newnym, tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Could TorButton check whether a download is in progress and, if so, give the user a choice whether to proceed?

It currently seems to be assumed that cancelling & clearing the download is acceptable. It doesn't provide any feedback to the user about this assumption either - their downloads just disappear.

As a simple fix, couldn't we just present a popup and clear this behavour with the user before creating the new identity?

"Choosing a new identity at this time will cancel your current downloads. Do you want to proceed?"

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by gk

Component: TorbuttonTor Browser
Keywords: tbb-torbutton tbb-newnym tbb-usablity added
Parent ID: #10426
Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

This might be an option for solving #10426. Marking this as a duplicate of it.

comment:2 Changed 4 years ago by bugzilla

Keywords: tbb-usability added; tbb-usablity removed
Severity: Normal

How can you close enhancement ticket as a duplicate of defect one?

This might be an option for solving #10426.

This might be an option to improve usability, if #10426 will not be solved.

Note: See TracTickets for help on using tickets.