Opened 4 years ago

Closed 4 years ago

#14541 closed defect (fixed)

Error converting OutboundBindAddress 192.0.2.23 into sockaddr.

Reported by: qbi Owned by:
Priority: Very High Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.2-alpha
Severity: Keywords: tor-relay regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Recently I upgraded to the latest Tor nightly build and the log files filled instantly with:

Jan 30 11:55:55.000 [warn] Error converting OutboundBindAddress 192.0.2.23 into sockaddr. Ignoring.

I switched back to an older version and the log messages disappeared. So I assume something was introduced between those two versions. A little digging in the code showed that commit ca5ba2956bcd4b5ee1e526ccf5914f52fe6e6d51 made a change in src/or/connection.c.

I didn't wait until the reachability test finished, because there were nearly 100000 lines of the message and I decided to roll back.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by nickm

Keywords: tor-relay regression added

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.6.x-final

comment:3 Changed 4 years ago by nickm

Resolution: fixed
Status: newclosed

d1e52d9a2a26c1bf9f80b237e692c72517c30495 should fix this. Please reopen if it doesn't?

Note: See TracTickets for help on using tickets.