Opened 5 years ago

Closed 3 years ago

#14637 closed defect (fixed)

New identity should show confirmation

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability uxsprint2015
Cc: gk, brade, mcs, saint, bastik.public@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We should make it more clear, when the user issues a "New Identity" request, that a New Identity has been created. Right now it shows about:tor again, but there isn't any message saying "You now have a new identity."

Child Tickets

Change History (7)

comment:1 Changed 5 years ago by gk

Cc: gk added

comment:2 Changed 5 years ago by mcs

Cc: brade mcs added

Since users may change their home page to something else, we probably need to use a popup or notification bar (at the top of the browser window) for this kind of notification. Also, it would be nice if there was a "Learn More" button included that took people to a web page that provided more info about Tor identities.

comment:3 Changed 5 years ago by saint

Cc: saint added

Users also don't necessarily know in advance that they will lose all tabs (including any current work) when they click it.

comment:4 in reply to:  3 Changed 5 years ago by intrigeri

Replying to saint:

Users also don't necessarily know in advance that they will lose all tabs (including any current work) when they click it.

Right, I've seen too many users be surprised that they just lost all their tabs. Now, this ticket seemed to originally be about confirming to the user after the fact that the New Identity operation was successful, while what saint and I are talking about suggests the need for a blocking confirmation asked to the user interactively before closing all tabs etc.

Note that such a confirmation message before switching identities may be needed for other reasons in the future: e.g. once Tor Browser is confined with AppArmor or something else, and only has access to a specific shared directory for downloading/uploading files, we may want to ask the user to move their files out of that directory before we switch identities, in order to avoid the content of that directory to be usable linkability information between before and after switching identities. We're currently discussing such ideas on the tails-ux@… mailing list, FYI.

comment:5 Changed 5 years ago by bastik

Cc: bastik.public@… added

comment:6 Changed 3 years ago by dcf

Severity: Normal

Duplicate of #9906, done in 4.5a4.

comment:7 Changed 3 years ago by saint

Resolution: fixed
Status: newclosed

Confirmed fixed. Closing.

Note: See TracTickets for help on using tickets.