Opened 5 years ago

Closed 4 years ago

#14685 closed enhancement (fixed)

BridgeDB should disable obfs2 distribution

Reported by: isis Owned by: isis
Priority: Low Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Normal Keywords: bridgedb-dist, bridgedb-pt
Cc: isis, sysrqb, Yawning Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The number of these bridges has dwindled quite significantly, and most of the bridges which used to offer obfs2 now offer obfs3 and/or obfs4. If someone is still really determined to use obfs2 for some odd reason, they can use https://bridges.torproject.org/bridges?transport=obfs2

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by isis

Weasel seems to think this shouldn't be done until there are some easy instructions for Bridge operators to run obfs4 on Debian Stable. See this tor-relays@ post.

comment:2 Changed 5 years ago by isis

Cc: Yawning added
Keywords: bridgedb-pt added
Priority: majorminor
Status: newneeds_information

Okay, the changes for this are in my fix/14865-disable-obfs2 branch, and should be merged whenever some suitable instructions exist for deploying obfs4 on Debian stable machines.

comment:3 Changed 4 years ago by isis

Resolution: fixed
Severity: Normal
Status: needs_informationclosed

Merged into master for bridgedb-0.3.4 and deployed.

Note: See TracTickets for help on using tickets.