Opened 5 years ago

Closed 5 years ago

#14739 closed defect (duplicate)

RecommendedTBBVersions does not advertise alpha versions anymore

Reported by: proper Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: proper Actual Points:
Parent ID: #14386 Points:
Reviewer: Sponsor:

Description

As per Tor blog, TBB 4.5a3 is currently considered alpha, while TBB 4.0.3 is considered stable.

RecommendedTBBVersions currently reads.

[
"4.0.3",
"4.0.3-Linux",
"4.0.3-MacOS",
"4.0.3-Windows",
"4.5a3",
"4.5a3-Linux",
"4.5a3-MacOS",
"4.5a3-Windows"
]

This breaks updaters such as torbrowser-launcher (bug report).

Questions:

  • Are the -alpha, -beta, -rc suffixed gone forever?
  • Or is 4.5a3 considered stable enough?
  • Or is the new RecommendedTBBVersions version format: "stable version at top, alpha on bottom"?

Related to:
#14383

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

The format is not formally specified and finalized yet, see your #14383. That said "a" indicates that this is an alpha version. Oh, and see our blog post https://blog.torproject.org/blog/tor-browser-45a3-released which makes an obvious connection between the "a" and the alpha version. Marking this as duplicate of #14383.

Note: See TracTickets for help on using tickets.