Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#14843 closed enhancement (duplicate)

Control: add command that fetches an HS descriptor on all hsdir for a given .onion

Reported by: dgoulet Owned by: dgoulet
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-hs, controller
Cc: Actual Points:
Parent ID: #13209 Points:
Reviewer: Sponsor: SponsorR

Description

Ticket for the command to be added to the control-spec document. An implementation ticket will be created once this is accepted. (You never know, might be a bad idea :)

Ref: https://lists.torproject.org/pipermail/tor-dev/2015-February/008230.html

The goal is to have a command on the control port that tells tor to fetch the HS descriptor on all HSDir for a given onion address. The full dump of the descriptor will be printed out as they come in. For instance:

C: setconf HS_DESC_FETCHALL onionorians.onion
S: 250 OK
[...]
S: 650 HS_DESC REQUESTED [...] <-- same as "HS_DESC" event
S: 650 HS_DESC RECEIVED [...] <-- same as "HS_DESC" event
S: 650 HS_DESC INFO
S: rendezvous-service-descriptor xz7f4tg4u3eam7iricupjz6qoupfyv3u
S: version 2
S: permanent-key
S: -----BEGIN RSA PUBLIC KEY-----
[...]

The command should also be able to take an optional list of hsdir to be used. This is an important feature needed for the HS health measurer (#13209).

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by dgoulet

Resolution: duplicate
Status: newclosed

Duplicate of #3521 as pointed out by rransom.

Also, thanks to rransom, the design in the original ticket is much better, to use GETINFO command to fetch on an hsdir but also another command to get it from the cache.

comment:2 Changed 4 years ago by dgoulet

Keywords: SponsorR removed
Sponsor: SponsorR

comment:3 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:4 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.