Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14852 closed defect (duplicate)

HS client connections should be killed when unconfigured?

Reported by: yawning Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-hs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I brought this up on IRC and someone argued that the current behavior is fine, but after talking to arma about it, he told me to open a ticket.

Currently when a Hidden Service is unconfigured at runtime, the intro circuit is killed, the hidden service is removed from the global list, and client connections are left as is.

This behavior is somewhat surprising, and a case can be made that "unconfigured is unconfigured" and client connections should be killed. The actual change would be done at the tail end of rend_configure_services().

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by yawning

Resolution: duplicate
Status: newclosed

It was pointed out that this is a duplicate of #4857.

comment:2 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:3 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.