Opened 5 years ago

Closed 4 years ago

#14864 closed enhancement (duplicate)

Add expert settings that let TorLauncher connect easily to a running tor instance

Reported by: cypherpunks Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords: TorLauncher, Torbutton, TBB, TorBrowser, Vidalia, ControlPort, ControlPassword
Cc: mcs, adrelanos@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Now that Vidalia is officially deprecated, I would like to propose adding expert settings to TorLauncher that let it connect easily to a running tor instance instead of starting a separate one.
I would strongly suggest GUI settings for extensions.torlauncher.start_tor=false, SocksPort, ControlPort and ControlPassword. Of course, it might be wise to add an "expert settings" warning.

To clarify where I am coming from:
I am using a system-wide tor instance (on Debian Wheezy 64bit) for TBB, torbirdy, and pidgin, among other clients.
I have to disable TorLauncher in TBB to get it to use the system-wide tor instance.
Doing that, I lose TorButton's "new identity" function, so right now I am using Vidalia to change the circuit when needed.
I am taking a wild guess I am not the only one doing something like that.

It would be much appreciated if there was an easy way to let TBB connect to a running tor instance without setting environment variables etc. (which never worked for me, anyway) and without losing the "new identity" feature.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by cypherpunks

Keywords: TorLauncher Torbutton TBB TorBrowser Vidalia ControlPort ControlPassword added

comment:2 Changed 5 years ago by mcs

Cc: mcs added

comment:3 Changed 5 years ago by proper

Cc: adrelanos@… added

comment:4 Changed 5 years ago by yawning

Isn't the correct fix for this is to make all the environment variables work? (See #9936, among other tickets). In the mean time, using cookie auth as in https://trac.torproject.org/projects/tor/wiki/TorBrowserBundle3SAQ worked fine the last time I did such things, though I have since moved onto doing something a bit more elaborate.

comment:5 Changed 5 years ago by cypherpunks

Isn't the correct fix for this is to make all the environment variables work? (See #9936, among other tickets).

No, this ticket is a proposal for adding user-friendly "Tor Control" settings (similar to those in Vidalia's "Advanced" settings) to Tor Launcher.

comment:6 Changed 4 years ago by mcs

Resolution: duplicate
Severity: Normal
Status: newclosed

This is a duplicate of #10160.

Note: See TracTickets for help on using tickets.