Opened 5 years ago

Closed 5 years ago

#14866 closed defect (fixed)

Tor circuit display sometimes shows out-of-date circuit if "New IP address for this site" is chosen

Reported by: arthuredelstein Owned by: arthuredelstein
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: TorBrowserTeam201502
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description


Child Tickets

Change History (6)

comment:1 Changed 5 years ago by arthuredelstein

Cc: mikeperry added
Owner: changed from tbb-team to arthuredelstein
Status: newassigned

comment:2 Changed 5 years ago by arthuredelstein

The following patch fixes the problem:

https://github.com/arthuredelstein/torbutton/commit/8a4aaab438e0ec1e361a28ecd5885c3a501e60cb

Before, when drawing the circuit display, we were only matching the page's domain to the circuit's SOCKS username (reported by the ControlPort). With this patch, we look up the page's proxyInfo object and use both username and password to find the correct circuit to display.

Last edited 5 years ago by arthuredelstein (previous) (diff)

comment:3 Changed 5 years ago by arthuredelstein

Keywords: TorBrowserTeam201502R added
Status: assignedneeds_review

comment:4 Changed 5 years ago by mikeperry

I just tried this out without wireshark or deep analysis of the actual SOCKS/proxyinfo behavior, but for a simple site like https://check.torproject.org the "New IP address for this site" option is still not causing a new circuit or IP to be used. I can dig deeper tomorrow, but thought I'd update the bug now with this info in case you're up earlier than I am.

comment:5 Changed 5 years ago by arthuredelstein

I neglected to mention here that my patch posted at
https://trac.torproject.org/projects/tor/ticket/9442#comment:21
is also necessary for the circuit to be correctly displayed. Had you applied it in your check.torproject.org test? I just confirmed again that with those two patches, check.torproject.org works for me.

comment:6 Changed 5 years ago by mikeperry

Keywords: TorBrowserTeam201502 added; TorBrowserTeam201502R removed
Resolution: fixed
Status: needs_reviewclosed

Ok, I finally got this working in a test build. Merged+Thanks!

Note: See TracTickets for help on using tickets.