Opened 5 years ago

Closed 5 years ago

#14915 closed defect (not a bug)

stem thinks "tor -f -" will work?

Reported by: arma Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

chingucha from irc points to
https://gitweb.torproject.org/stem.git/tree/test/integ/process.py#n234
where apparently stem is trying to run tor with "-f -" to have it read the torrc file from stdin.

That doesn't work, does it? I mean, it isn't supposed to work?

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by arma

Oh my, it does work.

    const int read_torrc_from_stdin =
    (f_line != NULL && strcmp(f_line->value, "-") == 0);

Carry on. Perhaps we should close this ticket? Or maybe wait until atagar has checked?

comment:2 Changed 5 years ago by arma

Looks like this feature is not in any released version of Tor yet though. Perhaps that was chingucha's issue.

comment:3 Changed 5 years ago by atagar

Resolution: not a bug
Status: newclosed

As discussed on irc stem has this test because it's among the tests its replacing in #14806. Feel free to reopen if Stem should change in some way...

https://gitweb.torproject.org/tor.git/tree/src/test/test_cmdline_args.py#n252

Note: See TracTickets for help on using tickets.