Opened 5 years ago

Closed 5 years ago

#14951 closed defect (duplicate)

User with SocksPort and DnsPort who visits an address that resolves to ipv6 gets confusing failure message?

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A while ago we had a user on irc who had a DnsPort and a SocksPort, transparent proxy style. He went somewhere that his dnsport resolved to an IPv6 address:

https://gitweb.torproject.org/tor.git/tree/src/or/dnsserv.c?id=6cb1daf062df525224ee7e3f7cd63ee858aacf9f#n147

But then later he tried reaching that address and his vanilla Socksport line didn't specify it could handle ipv6, or maybe it was some other issue, but in any case he ended up with this confusing warning message:

    log_warn(LD_EDGE, "I'm about to ask a node for a connection that I "
             "am telling it to fulfil with neither IPv4 nor IPv6. That's "
             "not going to work. Did you perhaps ask for an IPv6 address "
             "on an IPv4Only port, or vice versa?");

Maybe this bug is fixed already. Or maybe this person wasn't fully explaining his situation. But I figure it's better to file it than to leave it sitting in a browser tab for another two weeks.

Feel free to triage to 0.2.7 or to close if you think it's nonsense by now.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by arma

Oh hey, is this the same as #14280 ?

comment:2 Changed 5 years ago by nickm

There have been some bugs here, but I've got a bunch of this code fixed in 0.2.6.3-alpha. I think this could be #14280 , but it's hard to tell without explicit repro instructions.

comment:3 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

I'm going to tenatively call this a duplicate of #14280, but please reopen this ticket if 0.2.6.3-alpha has the same problem.

Note: See TracTickets for help on using tickets.