Opened 5 years ago

Closed 4 years ago

#14956 closed defect (fixed)

Loading faz.net produces loads of Rejecting-this-connection warnings in Tor Launcher (4.5 alpha)

Reported by: gk Owned by: jsha
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Take a Tor Browser 4.5 alpha, set the Tor Launcher log method to 0 and the log level to 1 and load faz.net. The result is loads of

[02-19 20:10:02] TorLauncher DBUG: Event response: 650 WARN Your application (using socks5 to port 443) gave Tor a malformed hostname: "$2.faz.net". Rejecting the connection. 

in your terminal. This does not happen in 4.0.4

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by yawning

FYI: The rejection is because of #13315.

comment:2 Changed 5 years ago by arthuredelstein

The $2 in the domain turned out to be caused by a regex bug in HTTPS-Everywhere. My patch is here:
https://github.com/EFForg/https-everywhere/pull/1099

comment:3 Changed 5 years ago by gk

Component: Tor BrowserEFF-HTTPS Everywhere

comment:4 Changed 5 years ago by gk

Owner: changed from tbb-team to jsha
Status: newassigned

comment:5 Changed 4 years ago by jsha

Resolution: fixed
Status: assignedclosed

arthuredelstein: Thanks for the pull request! See my comments on the GitHub request about needing to add tests.

In the meantime this is working because the FAZ rule is disabled.

Note: See TracTickets for help on using tickets.