Opened 4 years ago

Closed 4 years ago

#14974 closed enhancement (not a bug)

Onionoo should output full tor-exit-address

Reported by: naif Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This ticket is to improve onionoo to output the full list of tor exit address.

Today the only reliable source for IP addresses being used by Tor Exit Relay is
https://check.torproject.org/exit-addresses .

At Tor2web we are using onionoo but we need to switch to exit-addresses https://github.com/globaleaks/Tor2web-3.0/issues/125 .

The best solution would be if onionoo would also expose Tor Exit Relay IP addresses.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by karsten

Status: newneeds_information

Onionoo does include exit IP addresses. See the "a" field in summary documents or the "exit_addresses" field in details documents (https://onionoo.torproject.org/protocol.html). Is this not what you want?

comment:2 Changed 4 years ago by naif

@karsten is that exit_addresses deliverying the same results of https://check.torproject.org/exit-addresses ?

As i don't remember when, i've been told that onionoo does not deliver the effective list of Tor Exit IP address but only the public IP address of Tor Exit relay.

Am i wrong?

comment:3 Changed 4 years ago by karsten

Here's the specification of the "exit_addresses" field:

"Array of IPv4 or IPv6 addresses that the relay used to exit to the Internet in the past 24 hours. IPv6 hex characters are all lower-case. Only those addresses are listed that are different from onion-routing addresses. Omitted if array is empty."

It's probably this part that leads to some confusion here: "Only those addresses are listed that are different from onion-routing addresses."

Want to compare Check's list with Onionoo's list? Here's Onionoo's list of relays with OR addresses and exit addresses: https://onionoo.torproject.org/details?fields=fingerprint,or_addresses,exit_addresses

comment:4 Changed 4 years ago by naif

$ wget 'https://onionoo.torproject.org/details?fields=fingerprint,or_addresses,exit_addresses'
$ wget 'https://check.torproject.org/exit-addresses'

$ grep ExitAddre exit-addresses | awk '{ print $2}' | wc -l

1305

$ grep ExitAddre exit-addresses | awk '{ print $2}' | sort -rn | uniq | wc -l

1234

$ grep ExitAddre exit-addresses | awk '{ print $2}' | sort -rn | uniq > exit.txt

$ for i in cat exit.txt ; do echo -n "$i: " ; grep -c $i details\?fields\=fingerprint\,or_addresses\,exit_addresses ; done >> exit-out

$ wc -l exit-out

1234 exit-out

So, sounds like onionoo have all the Tor exit addresses that are also in that other file!

comment:5 Changed 4 years ago by karsten

Resolution: not a bug
Status: needs_informationclosed

Great. Closing as not-a-bug. Feel free to reopen if necessary.

Note: See TracTickets for help on using tickets.