Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#1500 closed defect (invalid)

Tor crash at starting with last git libevent2

Reported by: stars Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.12-alpha
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello, i have updated my libevent2 from git with the fix to can build it again but now Tot 0.2.2.13 alpha-dev commit 03dc1c786a9b154f17f9fd64ddf712d1ac9f30b0

The only error i get if i try to start Tor from the terminal are:

tor: error while loading shared libraries: libevent.so.4: cannot open shared object file: No such file or directory

Libevent commit caca2f451c3ecc97745f578bae9b4ad40145d84d

I run kubuntu lucid 10.04 LTS on x86 64 and before updated libevent, this Tor commit worked .

Best regards and hope that will be soon fixed, i can't start my relay anymore for the moment

Thanks, SwissTorExit

Child Tickets

Change History (4)

comment:1 Changed 11 years ago by stars

Priority: criticalnormal

Really wired, i insisted to compile a lot of time, both, libevent and Tor, each one almost 15 times .

Just on my last test, i start from the terminal and it started. I stop the process and start it like always via the controller and it worked again fine and i see that now it's libevent version 2.0.5-beta-dev who are used.

Maybe it will be good to try on a VM with Kubuntu Lucid LVM 10.04 x86 64 to see why it has so crashed.

Anyway i am really happy that my relay be running again :D

comment:2 Changed 10 years ago by nickm

Resolution: invalid
Status: newclosed

Neat; glad it worked out!

comment:3 Changed 8 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 8 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.