Opened 5 years ago

Closed 5 years ago

#15033 closed defect (fixed)

make check should ignore torrc

Reported by: reezer Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: 026-deferrable
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

make check should ignore the system wide torrc to avoid errors, especially when the torrc contains a User option and it is not being run as root. It probably also shouldn't interact with any already installed version of tor in general.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by nickm

Keywords: 026-deferrable added
Milestone: Tor: 0.2.6.x-final

Which parts of 'make check' use torrc? (If this is hard to fix, it can wait for 0.2.7 since it isn't a regression.)

comment:2 Changed 5 years ago by nickm

Ah, it's ./src/test/zero_length_keys.sh that's to blame:

./src/test/zero_length_keys.sh
Testing that tor correctly handles zero-length keys
Generating initial tor keys
Feb 26 15:17:21.024 [warn] Error setting configured user: fred not found

comment:3 Changed 5 years ago by nickm

Resolution: fixed
Status: newclosed

Should be fixed in d7fcaca3fcbc46c2aebe556c6649ce1eddb833dd. Thnanks!

Note: See TracTickets for help on using tickets.