Opened 4 years ago

Closed 4 years ago

#15034 closed defect (not a bug)

swap storm and MaxMemInQueues

Reported by: toralf Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I experienced at a hardened Gentoo Linux exit relay 3 times in the last 2 weeks a swap storm, resulting in writing 10 till 12 GB to swap.
This made the exit relay unresponsive for a longer time frame.

At least for the last time the swap storm seems to correlate with a lot of port scan connections over port 80 ("a lot" == 500 till 2000 and even more connections per seconds to a wide address range).

So I added today to torrc the line

MaxMemInQueues 4 GB

Anything else what I should do to narrow down the root cause ?

The linux kernel is a hardened 3.18.x linux, tor was 0.2.6.2-alpha (switched now to 2.6.3-alpha)

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by nickm

Milestone: Tor: 0.2.6.x-final

comment:2 Changed 4 years ago by nickm

(Anybody have insight about how to track this down?)

comment:3 Changed 4 years ago by toralf

FWIW: I do run 6 chroot images as a Gentoo QA build bot (== 1 compile job per chroot) but during that time frame there was no package which is known to use much RAM (eg. for the linker process)

comment:4 Changed 4 years ago by nickm

Milestone: Tor: 0.2.6.x-finalTor: 0.2.7.x-final

comment:5 Changed 4 years ago by toralf

Resolution: not a bug
Status: newclosed

well, never ever appeared here, will close it for now

Note: See TracTickets for help on using tickets.