Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1504 closed defect (duplicate)

No directory fetches, also #1374, 1375

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.1.26
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The same problem with TBB 0.2.1.26. The problem is no directory fetches anymore.
Best Regards
STHnet

maj 11 17:57:44.555 [Notice] Tor v0.2.1.26. This is experimental software. Do not rely on it for strong anonymity. (Running on Very recent version of Windows [major=6,minor=1] [workstation] {personal} {terminal services, single user})
maj 11 17:57:44.586 [Notice] Your ContactInfo config option is not set. Please consider setting it, so we can contact you if your server is misconfigured or something else goes wrong.
maj 11 17:57:44.586 [Notice] Initialized libevent version 1.4.12-stable using method win32. Good.
maj 11 17:57:44.586 [Notice] Opening OR listener on 0.0.0.0:443
maj 11 17:57:44.586 [Notice] Opening Socks listener on 127.0.0.1:9050
maj 11 17:57:44.586 [Notice] Opening Control listener on 127.0.0.1:9051
maj 11 17:57:44.586 [Notice] Parsing GEOIP file.
maj 11 17:57:49.827 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
maj 11 17:57:49.827 [Notice] Bootstrapped 100%: Done.
maj 11 17:57:50.311 [Notice] Now checking whether ORPort 217.208.70.200:443 is reachable... (this may take up to 20 minutes -- look for log messages indicating success)
maj 11 17:58:32.339 [Notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
maj 11 17:59:16.238 [Notice] Performing bandwidth self-test...done.
maj 12 20:58:35.521 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'dataway'. Retrying on a new circuit.
maj 13 10:58:36.594 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'KeithsReturn'. Retrying on a new circuit.
maj 13 11:10:18.983 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 12:58:35.572 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'PolandOnion'. Retrying on a new circuit.
maj 13 16:58:36.475 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Qwerty'. Retrying on a new circuit.
maj 13 22:04:09.178 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:29.667 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:29.667 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:03:51.975 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:13:16.742 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:15:09.343 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 13 23:19:25.948 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 11:13:07.807 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 11:14:45.166 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 17:51:45.006 [Notice] Tried for 121 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 17:58:51.090 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:13:56.500 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:15:21.722 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:15:21.722 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:17:00.143 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 15 18:17:00.143 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
maj 17 18:58:36.825 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'blutmagie2'. Retrying on a new circuit.
maj 17 20:58:40.683 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'blutmagie2'. Retrying on a new circuit.
maj 18 14:58:39.629 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Jisunglove'. Retrying on a new circuit.
maj 18 14:58:54.839 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'ZiMnEpIwO'. Retrying on a new circuit.
maj 18 15:58:36.605 [Notice] We tried for 15 seconds to connect to '[scrubbed]' using exit 'Shitblaster'. Retrying on a new circuit.
maj 18 19:00:26.103 [Notice] Our directory information is no longer up-to-date enough to build circuits: We have no recent network-status consensus.
maj 18 19:58:12.366 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 20:00:02.907 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 20:58:03.684 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 21:00:03.465 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 21:58:02.780 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 22:00:02.956 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
maj 18 22:09:37.882 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 18 22:11:37.050 [Notice] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)

Child Tickets

Change History (7)

comment:1 Changed 9 years ago by phobos

This sounds like a support issue, not a bug.

comment:2 Changed 9 years ago by phobos

Component: Polipo-Backend / CoreTor-Tor server
Priority: criticalnormal

comment:3 in reply to:  1 Changed 9 years ago by cypherpunks

Replying to phobos:

This sounds like a support issue, not a bug.

Thank you. Problem probably solved. Delete ticket: 1504,1374 and 1375. (Maybe also 1389?)
Best Regards
STHnet

maj 25 18:28:18.922 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 25 18:28:20.794 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 98/1658 usable descriptors.
maj 25 18:28:21.012 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 194/1658 usable descriptors.
maj 25 18:28:21.902 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 290/1658 usable descriptors.
maj 25 18:28:22.182 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 386/1658 usable descriptors.
maj 25 18:28:22.245 [Notice] We now have enough directory information to build circuits.
maj 26 16:56:36.474 [Notice] Application request when we're believed to be offline. Optimistically trying directory fetches again.
maj 26 16:56:38.502 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 96/1681 usable descriptors.
maj 26 16:56:38.564 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 191/1680 usable descriptors.
maj 26 16:56:38.642 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 287/1680 usable descriptors.
maj 26 16:56:38.752 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 337/1680 usable descriptors.
maj 26 16:56:39.064 [Notice] We now have enough directory information to build circuits.

comment:4 Changed 9 years ago by phobos

Resolution: duplicate
Status: newclosed

comment:5 Changed 8 years ago by karsten

Milestone: Tor: 0.2.1.26

Removing the milestone. Apparently, this problem showed up in 0.2.1.26 and wasn't meant to be solved in 0.2.1.26.

comment:6 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:7 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.