Opened 4 years ago

Closed 4 years ago

#15102 closed defect (duplicate)

Tor crashed with tor_assertion_failed_() in ../src/or/buffers.c:2627

Reported by: amki Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.5.10
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

unfortunately our tor relay just crashed today while relaying aroung 20MB/s data.

This is all I could find in the /var/log/tor/log:

Mar 02 11:02:23.000 [notice] Heartbeat: Tor's uptime is 30 days 6:00 hours, with 27608 circuits open. I've sent 63378.02 GB and received 61162.07 GB.
Mar 02 11:02:23.000 [notice] Average packaged cell fullness: 99.115%
Mar 02 11:02:23.000 [notice] TLS write overhead: 3%
Mar 02 11:02:23.000 [notice] Circuit handshake stats since last time: 216438/216438 TAP, 170322/170322 NTor.
Mar 02 11:18:54.000 [err] tor_assertion_failed_(): Bug: ../src/or/buffers.c:2627: assert_buf_ok: Assertion ch->data < &ch->mem[0]+ch->memlen failed; aborting.
Mar 02 11:18:54.000 [err] Bug: Assertion ch->data < &ch->mem[0]+ch->memlen failed in assert_buf_ok at ../src/or/buffers.c:2627. Stack trace:
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(log_backtrace+0x41) [0x7fc22b3d6191]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(tor_assertion_failed_+0x94) [0x7fc22b3e1d94]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(assert_buf_ok+0x167) [0x7fc22b3528a7]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(assert_connection_ok+0xce) [0x7fc22b38bbae]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(+0x35017) [0x7fc22b2fa017]
Mar 02 11:18:54.000 [err] Bug: /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x754) [0x7fc22a94af24]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(do_main_loop+0x195) [0x7fc22b2fb7b5]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(tor_main+0x18f5) [0x7fc22b2fe7a5]
Mar 02 11:18:54.000 [err] Bug: /lib/x86_64-linux-gnu/libc.so.6(libc_start_main+0xf5) [0x7fc229b2bec5]
Mar 02 11:18:54.000 [err] Bug: /usr/bin/tor(+0x32f5b) [0x7fc22b2f7f5b]

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by amki

Summary: Tor on a 30MB/s bridge crashed with tor_assertion_failed_() in ../src/or/buffers.c:2627Tor crashed with tor_assertion_failed_() in ../src/or/buffers.c:2627

comment:2 Changed 4 years ago by nickm

Duplicate of #15083.

comment:3 Changed 4 years ago by nickm

Resolution: duplicate
Status: newclosed

Duplicate of #15083.

Note: See TracTickets for help on using tickets.